summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLars Böckel2018-07-12 02:22:17 +0200
committerLars Böckel2018-07-12 02:22:17 +0200
commit0895f043e5c1a175a7c6f4ca5ce4861b20a32e45 (patch)
treee027026de8196224b7abe162520252bd1dbe304f /PKGBUILD
downloadaur-0895f043e5c1a175a7c6f4ca5ce4861b20a32e45.tar.gz
first release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86c8604f26d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer RetardedOnion@archlinux-irc
+# Original PKGBUILD from notepadqq
+## Maintainer: Balló György <ballogyor+arch at gmail dot com>
+## Contributor: Doug Newgard <scimmia at archlinux dot info>
+
+pkgname=notepadqq-legacy
+pkgver=1.3.6
+pkgrel=1
+pkgdesc='Notepad++-like text editor for Linux. Legacy version which doesnt ask for restoration at startup.'
+arch=('x86_64')
+url='https://notepadqq.altervista.org/'
+license=('GPL3')
+depends=('hicolor-icon-theme' 'qt5-svg' 'qt5-webkit')
+provides=('notepadqq')
+conflicts=('notepadqq')
+makedepends=('git' 'qt5-tools')
+options=('!emptydirs')
+_commit=2cc6f12a04d51947891d77a5a329a5dd07e28ff7 #1.3.6 commit
+source=("git+https://github.com/notepadqq/notepadqq.git#commit=$_commit"
+ "git+https://github.com/notepadqq/CodeMirror.git")
+
+pkgver() {
+ cd notepadqq
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
+prepare() {
+ cd notepadqq
+ git config submodule.src/editor/libs/codemirror.url "$srcdir/CodeMirror"
+ git submodule update --init
+}
+
+build() {
+ cd notepadqq
+ qmake-qt5 PREFIX=/usr LRELEASE=/usr/bin/lrelease notepadqq.pro
+ make
+}
+
+package() {
+ cd notepadqq
+ make INSTALL_ROOT="$pkgdir" install
+}
+sha256sums=('SKIP'
+ 'SKIP')