summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCandroid-man2021-12-11 05:02:07 -0600
committerCandroid-man2021-12-11 05:02:07 -0600
commit6540fb959cca61c3246676db11371693829e4743 (patch)
tree476557e6e9d23d863b01a338cb648fb450f6f489 /PKGBUILD
downloadaur-6540fb959cca61c3246676db11371693829e4743.tar.gz
Initial push
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..721e035e7d0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: candroid_man <candroid_man@protonmail.com>
+# Contributer: Ada <adadonderr@gmail.com>
+# Contributor: Christian Finnberg <christian@finnberg.net>
+pkgname='notesnook-git'
+pkgver=1.6.11
+pkgrel=1
+pkgdesc="Take private notes, capture ideas, make lists & sync them anywhere"
+arch=('x86_64')
+url="https://notesnook.com/"
+license=('Unknown')
+depends=('gtk3' 'nss')
+source=("${pkgname}_${pkgver}_amd64.deb"::"https://github.com/streetwriters/$pkgname/releases/download/v$pkgver/${pkgname}_amd64.deb")
+sha256sums=('1633b7989f49c4cb119cff2aeaa696b9252cae4f43361a0bd0dce64fbb1ac674')
+
+package() {
+ bsdtar -xf data.tar.xz -C "$pkgdir"
+
+ # Link to the binary
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s '/opt/Notesnook/Notesnook' "${pkgdir}/usr/bin/Notesnook"
+}
+
+post_install() {
+ # SUID chrome-sandbox for Electron 5+
+ chmod 4755 "${pkgdir}/opt/Notesnook/chrome-sandbox" || true
+
+ update-mime-database /usr/share/mime || true
+ update-desktop-database /usr/share/applications || true
+}