summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSibren Vasse2023-08-07 17:59:16 +0200
committerSibren Vasse2023-08-07 17:59:16 +0200
commita892b300c45217aa08cd6a4b567c75a695d7348d (patch)
tree90f654e5cb4f6088284ccfa9f2ea307a798d50f3 /PKGBUILD
parent0f971c1622eba6c52883a0044dc4e341f50f8d8e (diff)
downloadaur-a892b300c45217aa08cd6a4b567c75a695d7348d.tar.gz
v3.7.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 75b650896a84..f616cd786495 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Sibren Vasse <arch@sibrenvasse.nl>
pkgname=noti
-pkgver=3.5.0
+pkgver=3.7.0
pkgrel=1
pkgdesc='Monitor a process and trigger a notification'
arch=('x86_64')
url='https://github.com/variadico/noti'
license=('MIT')
makedepends=('go')
-source=("https://github.com/variadico/noti/archive/$pkgver.tar.gz")
-sha256sums=('04183106921e3a6aa7c107c6dff6fa13273436e8a26d139e49f34c5d1eea348c')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/variadico/noti/archive/$pkgver.tar.gz")
+sha256sums=('f970a4dd242e6b58edf51320aa237bb20d689bbc8fd0f7d0db5aa1980a2dc269')
build() {
cd "$pkgname-$pkgver"
go build \
-trimpath \
-buildmode=pie \
- -mod=vendor \
+ -mod=readonly \
-modcacherw \
- -ldflags "-extldflags \"${LDFLAGS}\"" \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\"" \
-o $pkgname \
github.com/variadico/noti/cmd/noti
}