summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBalló György2014-05-11 18:49:23 +0000
committerBalló György2014-05-11 18:49:23 +0000
commit5255ab98c60e88b221804c43fcc8b9c0e4daf6f6 (patch)
tree7123a4b53c977d707cc318d55e84bb2b14344c45 /PKGBUILD
downloadaur-5255ab98c60e88b221804c43fcc8b9c0e4daf6f6.tar.gz
Add new dependencies of sparkleshare
- gtk-sharp-3 - notify-sharp-3 - soup-sharp - webkitgtk-sharp
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71c022d12e9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Jorge Mokross <mokross@gmail.com>
+
+pkgname=notify-sharp-3
+_pkgname=notify-sharp
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="C# D-Bus client library for desktop notifications (GTK+ 3 version)"
+arch=('any')
+url="https://www.meebey.net/projects/notify-sharp/"
+license=('MIT')
+depends=('gtk-sharp-3' 'dbus-sharp-glib')
+source=(https://www.meebey.net/projects/$_pkgname/downloads/$_pkgname-$pkgver.tar.gz
+ avoid-confilct.patch)
+sha256sums=('5fb25f6ce9a3c27f0a6b927ee0a4ef6d02f6e6a2b8037d4dd525977840bd9345'
+ '35ddc863f8999850d7444693a33c439b646cd5728a723a12eecdc8cc47808779')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ # Avoid conflict with notify-sharp 2
+ patch -Np1 -i ../avoid-confilct.patch
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ autoreconf -fi
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}