summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrancois Truphemus (melchips)2015-07-06 22:32:40 +0200
committerFrancois Truphemus (melchips)2015-07-06 22:32:40 +0200
commita6711349890cb034e8aa92997e9e635252a93bbe (patch)
tree5accfe574945c9bba55fff755c0c6a7f57fac495 /PKGBUILD
downloadaur-notify-sharp-git.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8527fce60335
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: melchips <truphemus dot francois at gmail dot com>
+
+pkgname=notify-sharp-git
+_gitname=notify-sharp
+pkgver=3.0.0.r0.gc94bcc9
+pkgrel=1
+pkgdesc="C-sharp client implementation for Desktop Notifications, i.e. notification-daemon"
+arch=('i686' 'x86_64')
+url="https://git.gnome.org/browse/notify-sharp/"
+license=('MIT')
+depends=('mono' 'gtk-sharp-git')
+makedepends=('git')
+options=('!libtool')
+provides=('notify-sharp')
+conflicts=('notify-sharp')
+source=("$_gitname"::'git://git.gnome.org/notify-sharp')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+
+ msg2 "Starting make..."
+ ./autogen.sh --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/${_gitname}
+ make DESTDIR=${pkgdir} install || return 1
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}