summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormatclab2018-04-21 18:34:17 +0200
committermatclab2018-04-21 18:37:19 +0200
commit317982d42837357204291d5c64cb9c47e34c8f63 (patch)
tree65fe1c2d85f4066959896adc9d28f6dab30e340b /PKGBUILD
downloadaur-317982d42837357204291d5c64cb9c47e34c8f63.tar.gz
Initial revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f452f1a6b553
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+#Contributor: mathieu.clabaut <mathieu.clabaut@gmail.com>
+
+pkgname=notifymuch-git
+pkgver=r39.9d4aaf5
+pkgrel=1
+pkgdesc="Display desktop notifications for unread mail in notmuch database"
+arch=('i686' 'x86_64')
+url="https://github.com/kspi/notifymuch"
+license=('GPL2')
+provides=('notifymuch')
+makedepends=( 'pygobject-devel')
+depends=('python' 'notmuch' 'python-setuptools' )
+optdeps=()
+source=('notifymuch::git://github.com/kspi/notifymuch')
+md5sums=('SKIP')
+
+
+build() {
+ cd $srcdir/notifymuch
+ python setup.py build || return 1
+}
+
+package() {
+ cd $srcdir/notifymuch
+ python setup.py install --root=$pkgdir || return 1
+}
+
+
+pkgver() {
+ cd "$srcdir/notifymuch"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}