summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM Rawash2017-12-27 11:36:51 +0200
committerM Rawash2017-12-27 11:36:51 +0200
commit7bf3e6e404ab63caac93c711a3581c820059f0c5 (patch)
treed349ae30977b229bc2e471a70cc4f42da250d07a /PKGBUILD
parent5f9a3048d08791d0bd8cd551ec534da2352b599a (diff)
downloadaur-7bf3e6e404ab63caac93c711a3581c820059f0c5.tar.gz
added contrib scripts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 872990014203..2fce7d8f7b4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: M Rawash <mrawash@gmail.com>
pkgname=notion-git
-pkgver=3.2015061300.r55.3ae6b5f7
+pkgver=3.2017050501.r16.g7260b922
pkgrel=1
pkgdesc='Tabbed tiling, window manager. Fork of Ion3 - git version'
arch=('i686' 'x86_64')
@@ -9,24 +9,25 @@ license=('custom:LGPL')
depends=('glib2' 'lua' 'libxext' 'libsm' 'gettext')
optdepends=('libxinerama' 'libxrandr')
makedepends=('git')
-provides=('libtu' 'libextl' 'notion')
-conflicts=('notion')
-source=('notion::git+https://github.com/raboof/notion.git')
+provides=('libtu' 'libextl' ${pkgname%-git})
+conflicts=(${pkgname%-git})
+source=("$pkgname::git+https://github.com/raboof/notion.git#branch=master")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/notion"
- printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ cd "$srcdir/$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/notion"
+ cd "$srcdir/$pkgname"
export PREFIX=/usr
export ETCDIR=/etc/notion
make
}
package() {
- cd "$srcdir/notion"
+ cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir/" install
+ cp -R contrib "$pkgdir/usr/share/"
}