summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2017-07-23 22:00:13 +0200
committerhaawda2017-07-23 22:00:13 +0200
commit687f03e3c201066d0f461a6f0d2451cd90693a58 (patch)
treec33fc233b6398911dba79c5e572ca11f7c8543b2 /PKGBUILD
parentc98681a22c9680409b64f8d83bcc38b6990ed0b1 (diff)
downloadaur-687f03e3c201066d0f461a6f0d2451cd90693a58.tar.gz
switch (temporarily?) to github mirror, repome patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa2fdcdc91b8..ef6f2d48170e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,16 +8,15 @@
pkgbase=notmuch-git
_pkgname=notmuch
pkgname=('notmuch-git' 'notmuch-vim-git' 'notmuch-mutt-git' 'notmuch-runtime-git')
-pkgver=0.25_rc1.2.1.gc28ac94a
-pkgrel=1
+pkgver=0.25_rc1.2.0.gd95ccfe9
+pkgrel=2
arch=('i686' 'x86_64')
url="https://notmuchmail.org/"
license=('GPL3')
makedepends=('python2' 'python' 'python-sphinx' 'emacs' 'gnupg' 'ruby' 'pkgconfig' 'xapian-core' 'gmime' 'talloc')
options=(!distcc !makeflags)
-source=("git://notmuchmail.org/git/notmuch" not_byte_compile_notmuch_el.patch)
-md5sums=('SKIP'
- '07fa5cbbf2c7e0d5a19352c652e9c9cf')
+source=("git+https://github.com/notmuch/notmuch")
+md5sums=('SKIP')
pkgver() {
cd ${_pkgname}
@@ -28,13 +27,10 @@ prepare(){
cp -dpr --no-preserve=ownership "$srcdir/${_pkgname}"/bindings/python{,2}
find "$srcdir/${_pkgname}/bindings/python" -name '*.py' -exec sed -i -e '1s,python$,python3,' {} +
find "$srcdir/${_pkgname}/bindings/python2" -name '*.py' -exec sed -i -e '1s,python$,python2,' {} +
- cd $_pkgname
- patch -Np1 < $srcdir/not_byte_compile_notmuch_el.patch||true
}
build() {
cd $_pkgname
-
./configure --prefix=/usr --sysconfdir=/etc --includedir=/usr/include --without-zsh-completion
make
@@ -73,7 +69,6 @@ package_notmuch-vim-git(){
make -C ${_pkgname}/vim DESTDIR="$pkgdir" prefix="/usr/share/vim/vimfiles" install
}
-
package_notmuch-git(){
pkgdesc="Not much of an email program"
depends=('notmuch-runtime')
@@ -91,7 +86,7 @@ package_notmuch-git(){
# Install emacs parts
make DESTDIR="$pkgdir/" install-emacs
-
+
# Install manpages
make DESTDIR="$pkgdir" prefix="/usr" install-man