summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBuildTools2021-04-29 14:40:34 -0400
committerBuildTools2021-04-29 14:40:34 -0400
commit64acad272d353deee0b2edbe69c55dc3f15f72f0 (patch)
treea07e104a2a051ba9e52ff25febb65fa1909109a5 /PKGBUILD
downloadaur-64acad272d353deee0b2edbe69c55dc3f15f72f0.tar.gz
Setup package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd9b0d1c78b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Matt C <matt@xhec.us>
+# Upstream author: jnats <jnats@salyut.one>
+pkgname=nowpm-git
+_pkgname=nowpm
+pkgver=1.0
+pkgrel=1
+pkgdesc="the no-bullshit wpm utility"
+arch=('any')
+url="https://github.com/jnats/nowpm"
+license=('custom:beerware')
+depends=('coreutils' 'grep' 'sed' 'bash')
+provides=('nowpm')
+
+source=("nowpm::git+https://github.com/jnats/nowpm.git")
+
+md4sums=("SKIP")
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ mkdir -p $pkgdir/usr/share/licenses/$_pkgname
+ cd $_pkgname
+ chmod +x nowpm
+ cp nowpm $pkgdir/usr/bin
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}
+md5sums=('SKIP')