summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohannes Löthberg2014-02-26 17:35:03 +0100
committerJohannes Löthberg2015-06-08 12:21:09 +0200
commit3a35d17325063b88191a79fe6239166dcec93efb (patch)
tree10fce5518633e513b4d5de39c3b15d322a3c8917 /PKGBUILD
downloadaur-3a35d17325063b88191a79fe6239166dcec93efb.tar.gz
np1-mps{,-git}: Added new packages.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7438c73a21b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
+
+pkgname=np1-mps-git
+pkgver=git
+pkgrel=1
+pkgdesc="Terminal based YouTube jukebox with playlist management"
+arch=('any')
+url='https://github.com/np1/mps'
+license=('GPL3')
+depends=('python')
+optdepends=('mpv: Alternative to mplayer for playback'
+ 'mplayer: Alternative to mpv for playback')
+conflicts=('np1-mps')
+install=np1-mps-git.install
+source=('git+https://github.com/np1/mps.git' 'np1-mps-git.install')
+md5sums=('SKIP'
+ '26c08fc68ce960f1cc3a7f3f9157fa27')
+
+pkgver() {
+ cd mps
+ git describe --tags --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd mps
+ python setup.py install --root="$pkgdir" --optimize=1
+}