summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorny-a2020-03-28 22:49:53 +0900
committerny-a2020-03-28 23:40:45 +0900
commit09ac1b8b1354f59cbc07b9bce9838047b05b04dc (patch)
tree15b3325eec6360481c144e2d879a293984036ce2 /PKGBUILD
parent0ce048b4158faee9b8e74dbb3ecafaf0ac5f465a (diff)
downloadaur-npapi-vlc.tar.gz
Update to 3.0.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eec50f5fb39e..3a8f28e1f9a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
-
-# Maintainer: LightDot <lightdot -a-t- g m a i l>
+# Maintainer: ny-a <nyaarch64@gmail..com>
+# Contributor: LightDot <lightdot -a-t- g m a i l>
# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
# Contributor: Det <nimetonmaili g-mail>
# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
pkgname=npapi-vlc
-pkgver=2.2.6
+pkgver=3.0.3
pkgrel=1
pkgdesc="The modern VLC Mozilla (NPAPI) plugin."
arch=('x86_64')
@@ -14,16 +14,12 @@ license=('GPL')
depends=('gtk2' 'vlc')
makedepends=('git' 'npapi-sdk')
# This package uses version tags from Git, because there are no official releases
-source=("git+https://code.videolan.org/videolan/$pkgname.git#tag=$pkgver"
- "git+https://code.videolan.org/videolan/libvlcpp.git")
-md5sums=('SKIP'
- 'SKIP')
+source=("git+https://code.videolan.org/videolan/$pkgname.git#tag=$pkgver")
+md5sums=('SKIP')
prepare() {
cd "$pkgname"
- git submodule init
- git config submodule.vlcpp.url "$srcdir/libvlcpp"
- git submodule update
+ git submodule update --init
}
build() {
@@ -38,4 +34,6 @@ package() {
cd "$pkgname"
make DESTDIR="$pkgdir" install
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}