summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOscar Cowdery Lack2023-08-17 11:53:42 +1000
committerOscar Cowdery Lack2023-08-17 11:53:42 +1000
commite5c3439d7b8231a6addc1a3538ab3696e5911b9c (patch)
treec33b5a26fdeb2e23bc5c73c9647206c6112a56c5 /PKGBUILD
downloadaur-e5c3439d7b8231a6addc1a3538ab3696e5911b9c.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..014f096a7952
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Oscar Cowdery Lack <oscar.cowderylack@gmail.com>
+pkgname=nsc
+pkgver=2.8.0
+pkgrel=1
+pkgdesc="A tool for creating NATS account and user access configurations"
+arch=(x86_64)
+url="https://github.com/nats-io/nsc"
+license=('Apache')
+makedepends=(go)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('318d28528bdd36abb929bb75b396cd8d4bee7b32c68a5c0be1786a168cec6ec9')
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build .
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 ./$pkgname "$pkgdir"/usr/bin/$pkgname
+}