summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMantas Mikulėnas2022-12-19 12:38:08 +0200
committerMantas Mikulėnas2022-12-19 12:38:08 +0200
commit26c00cf0aaebe8cae249a28a6a93e7cac9cf579d (patch)
tree4cf594107448023a1ab3bc9fd8d84fdee3171347 /PKGBUILD
parentc0c0738e3d51b5fc5725502c727b2cfbf3c851d3 (diff)
downloadaur-26c00cf0aaebe8cae249a28a6a93e7cac9cf579d.tar.gz
release 1.82+git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eaa35945f915..85159f5c2786 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=nsdiff
-pkgver=1.81
+pkgver=1.82
pkgrel=1
pkgdesc="Create an 'nsupdate' script from DNS zone file differences"
url="https://dotat.at/prog/nsdiff/"
@@ -16,13 +16,23 @@ provides=(
perl-dns-nsdiff=$pkgver
)
options=(!emptydirs)
-source=("https://dotat.at/prog/nsdiff/DNS-nsdiff-$pkgver.tar.gz")
-sha256sums=('869dddadfe5f137855da41e1705a43dbf1f60d31374edc8822c827f2b7ed4d41')
+source=("https://dotat.at/prog/nsdiff/DNS-nsdiff-$pkgver.tar.gz"
+ 0001-nsvi-forward-g-to-nsupdate.patch
+ 0002-nsvi-g-documentation.patch)
+sha256sums=('9e37c68be73179a5e52f946c472930c1401b27fbd3a5bde9199070fd6926d418'
+ 'ddf92ddace522ee1410a71b8f88a8d058c0886c6804155aa83c13ce1d4c55ad7'
+ 'a65c042dcace11a03de1018e885754038ace824e1601547390c32dcb31dd40de')
#_commit=f2979fd03bbede624709700dfb65b26d94a0f2f2 # 1.81
#source=("git+https://github.com/fanf2/nsdiff.git#commit=$_commit")
#source=("git+https://git.uis.cam.ac.uk/x/uis/ipreg/nsdiff.git=$_commit")
#sha256sums=('SKIP')
+prepare() {
+ cd DNS-nsdiff-$pkgver
+ patch -Np1 < ../0001-nsvi-forward-g-to-nsupdate.patch
+ patch -Np1 < ../0002-nsvi-g-documentation.patch
+}
+
build() {
cd DNS-nsdiff-$pkgver
perl Makefile.PL INSTALLDIRS=vendor