summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2016-10-22 16:40:25 +0200
committerMichel Zou2016-10-22 16:40:25 +0200
commit614d4b9630313cd7c7b35e13056f7d59b25941f0 (patch)
tree636a23dea02cdfb9a78a52c46f675f740d7c0a54 /PKGBUILD
parent40a0354197d7236cb78f4e29c823a5ea74495518 (diff)
downloadaur-614d4b9630313cd7c7b35e13056f7d59b25941f0.tar.gz
3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 9 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd18fcff2ddd..b7c4cf22e591 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Andre Klitzing <andre () incubo () de>
pkgname=nsis
-pkgver=2.51
+pkgver=3.0
pkgrel=1
pkgdesc='A professional open source system to create Windows installers'
arch=('i686' 'x86_64')
@@ -11,44 +11,25 @@ license=('custom:zlib')
depends=('gcc-libs')
makedepends=('scons' 'mingw-w64-gcc')
options=(!strip)
-source=(http://downloads.sourceforge.net/project/nsis/NSIS%202/$pkgver/$pkgname-$pkgver-src.tar.bz2
- nsis-2.43-64bit-fixes.patch
- nsis-2.45-static-libgcc.patch
- nsis-2.46-missing-unistd-include.patch
- nsis-2.46-static-libstdc++.patch
- nsis-add-mingw-w64-support.patch
- nsis-948074.patch)
-md5sums=('002538226a72a38ba1abb0d5d4ffdc45'
- '9eead3b78da54e3afda8f6a5b663aea9'
- '28f1002dd3c6a57cd3e1f8bb09c81fc5'
- 'c4f912f0ca7fa455948f9f6a73314d93'
- '3d41bf574cd3bed0c4f14afca9bc4819'
- 'd72c910fa1e9b8372fadf1ba905139ab'
- '9b94bfb75b4dcfd3872c7fa2573d2ee5')
+source=(http://downloads.sourceforge.net/project/nsis/NSIS%203/$pkgver/$pkgname-$pkgver-src.tar.bz2
+ nsis-add-mingw-w64-support.patch)
+md5sums=('23d2e0f58e7ea3b2df2c16791896a6f1'
+ '39c4d9f24fd18b999c2a487e2bbcb788')
prepare() {
cd "$srcdir/$pkgname-$pkgver-src"
- # http://pkgs.fedoraproject.org/cgit/mingw-nsis.git/tree/
- patch -p1 -i "$srcdir/nsis-2.43-64bit-fixes.patch"
- patch -p1 -i "$srcdir/nsis-2.45-static-libgcc.patch"
- patch -p1 -i "$srcdir/nsis-2.46-missing-unistd-include.patch"
- patch -p1 -i "$srcdir/nsis-2.46-static-libstdc++.patch"
- patch -p1 -i "$srcdir/nsis-add-mingw-w64-support.patch"
-
- # https://bugzilla.redhat.com/show_bug.cgi?id=948074
- patch -p1 -i "$srcdir/nsis-948074.patch"
- # https://github.com/kichik/nsis/pull/4
- sed -i "s|__attribute__((__stdcall__))|\"__attribute__((__stdcall__))\"|g" SCons/Config/gnu
+ # https://github.com/kichik/nsis/commit/4677332
+ patch -p1 -i "$srcdir/nsis-add-mingw-w64-support.patch"
}
build() {
cd "$srcdir/$pkgname-$pkgver-src"
- scons VERSION=$pkgver PREFIX=/usr PREFIX_CONF=/etc SKIPUTILS='NSIS Menu' STRIP_CP=false
+ scons VERSION=$pkgver PREFIX=/usr PREFIX_CONF=/etc SKIPUTILS='NSIS Menu' STRIP_CP=false ZLIB_W32=/usr/i686-w64-mingw32/
}
package() {
cd "$srcdir/$pkgname-$pkgver-src"
- scons VERSION=$pkgver PREFIX=/usr PREFIX_CONF=/etc SKIPUTILS='NSIS Menu' STRIP_CP=false PREFIX_DEST="$pkgdir" install
+ scons VERSION=$pkgver PREFIX=/usr PREFIX_CONF=/etc SKIPUTILS='NSIS Menu' STRIP_CP=false ZLIB_W32=/usr/i686-w64-mingw32/ PREFIX_DEST="$pkgdir" install
install -Dm644 ${srcdir}/$pkgname-$pkgver-src/Docs/src/license.but "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}