summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTobias Rueetschi2016-07-18 17:42:06 +0200
committerTobias Rueetschi2016-07-18 17:42:06 +0200
commit3e70f7e79d681fc8824decd51cc1e158f9b69eec (patch)
tree3fc1c6985dc0e647fdf3035e450f4bb33f6deea5 /PKGBUILD
downloadaur-3e70f7e79d681fc8824decd51cc1e158f9b69eec.tar.gz
adding version 0.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9186e90e1e16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Author: Tobias Rueetschi <tr+archlinux at brief dot li>
+
+pkgname='nsntrace'
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Perform network trace of a single process by using network namespaces."
+arch=('i686' 'x86_64')
+url="https://github.com/jonasdn/nsntrace.git"
+license=('GPL2')
+groups=()
+depends=('libnl')
+makedepends=('git' 'automake')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(git+https://github.com/jonasdn/nsntrace.git)
+noextract=()
+md5sums=()
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}