summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Gamble2022-01-26 14:36:39 +1100
committerMatthew Gamble2022-01-26 14:36:39 +1100
commite0702ea028bb7d068eef914ff5e650ea9258082c (patch)
tree36e18a71bc8397b4a744edba775663a8b605b4f1 /PKGBUILD
parent02ec73b4f380bab7cea4e4ed6699f59c3d08080b (diff)
downloadaur-e0702ea028bb7d068eef914ff5e650ea9258082c.tar.gz
Bump pkgrel for python3.10 rebuild, other cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 073c525dd176..126ace1f883c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=nspawn-tools
pkgver=1.1.2
-pkgrel=4
+pkgrel=5
pkgdesc="Convenience code for dealing with systemd-nspawn machines"
arch=("any")
url="https://github.com/djmattyg007/nspawn-tools"
@@ -12,8 +12,17 @@ makedepends=("python-setuptools")
source=("https://github.com/djmattyg007/nspawn-tools/archive/${pkgver}.tar.gz")
sha512sums=("5900f959ac1f5267b69b48e1aca45b3407609870b1c05f84d1a94fceaa46cc327ef083e400310c974b995be324b642af5a8db45f64cb006f3538ea6e846fe9f4")
+build() {
+ cd "nspawn-tools-${pkgver}"
+
+ python setup.py build
+}
+
package() {
cd "nspawn-tools-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+
+ PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/nspawn-tools/LICENSE.txt"
+ install -Dm644 README.txt "${pkgdir}/usr/share/doc/nspawn-tools/README.txt"
}