summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Armbruster2020-04-20 16:51:03 +0200
committerMichael Armbruster2020-04-20 16:51:03 +0200
commitd0f9bc1b204b59ec520e4019ee532e2fc5b4a361 (patch)
tree8aaeef4a11eff973e374ad4d0ffe59b4f6ee9fda /PKGBUILD
parent0b33debc4092c3c877e8f0de1746493faf1a1469 (diff)
downloadaur-d0f9bc1b204b59ec520e4019ee532e2fc5b4a361.tar.gz
Prevent broken shell after application exits
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6f142f6f861..497b2f9517be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michael Armbruster <michael at armbrust dot me>
pkgname=nsz-git
-pkgrel=2
+pkgrel=3
pkgver=3.1.1.r25.g571147e
pkgdesc='Switch Homebrew compatible NSP/XCI compressor/decompressor'
conflicts=("${pkgname%-*}")
@@ -12,14 +12,20 @@ license=('MIT')
depends=('python>=3.6' 'python-pycryptodome>=3.9.0' 'python-zstandard' 'python-enlighten')
optdepends=('python-pygame' 'python-kivy==1.11.1')
makedepends=('git' 'python-setuptools')
-source=("${pkgname}::git+https://github.com/nicoboss/${pkgname%-*}.git")
-sha256sums=('SKIP')
+source=("${pkgname}::git+https://github.com/nicoboss/${pkgname%-*}.git"
+ '0001-Stopping-the-bar-manager-is-needed-to-properly-reset.patch')
+sha256sums=('SKIP'
+ '55171dd660017e425ddcd73cb76ce684d3ce41cb997d8fd6e50263a91a2c4997')
pkgver() {
cd "${pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ patch -d "${pkgname}" -Np1 -i "${srcdir}/0001-Stopping-the-bar-manager-is-needed-to-properly-reset.patch"
+}
+
build() {
cd "${pkgname}"
python setup.py build