summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHanabishi2022-05-31 21:03:13 +0500
committerHanabishi2022-05-31 21:03:13 +0500
commitb2d442af65ca0779dfc16bbd297f1242661e07c8 (patch)
treeb6be8d1e5104c834f9ecc39550f1a698e83c155f /PKGBUILD
parent3f7a04b61009b3a7593e979d8dde08538676ac18 (diff)
downloadaur-b2d442af65ca0779dfc16bbd297f1242661e07c8.tar.gz
New version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 5 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87f71754f0c2..6b9d22448681 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=ntfs3-dkms-git
-pkgver=5.15.r9.g52e00ea
-pkgrel=5
+pkgver=5.18.r1.gf26967b
+pkgrel=1
epoch=1
pkgdesc="NTFS3 is fully functional NTFS Read-Write driver. The driver works with NTFS versions up to 3.1."
arch=('any')
@@ -12,28 +12,18 @@ provides=('NTFS3-MODULE' 'ntfs3')
conflicts=('ntfs3')
options=('!strip' '!emptydirs')
-_patches=(
- "kernel-5."{12,14,15}"-backport.patch"
- "kernel-5.16.patch"
-)
-
source=(
"Makefile.patch"
"dkms.conf"
- "${_patches[@]}"
)
sha256sums=(
'fd4cf0e2dc160efecc55d4ea99667669b870599e4e81be435ec2201381b7e2ac'
- '1c7c30b21878f15d5eacc2fda563d94fd7491f1681818b7ca7a377c588abf2f4'
- 'b1674d6bb9b255a059efc4eae0846a426620a7a236dff19f4d0f85dfe2bbfd0d'
- 'f176a508596d0021beae0af264f2ef92d46062c7b12e89e4f4e8104d91118d85'
- '69c315bbb37e831adacedaa5eff1b32571ef86a24dcdb2a312a015bf824f6569'
- 'e61b3876ad3b474229ee6707cb7664783cdd6888676dfc433b49a45682083d5a'
+ '82e2d9cc730188973d6c5ed91736373e5afbba74f7a73003dd38761800ac8bd9'
)
-_ver="5.15"
-_since="1635713590"
+_ver="5.18"
+_since="1653249151"
# The whole kernel history is very huge, so downloading it is a pain.
# Also commits count is insane and we don't want to see all that in pkgver.
@@ -61,12 +51,6 @@ prepare() {
cd "fs/ntfs3"
patch -i "${srcdir}/Makefile.patch"
-
- # For testing
- # patch -i "${srcdir}/${_patches[-1]}"
- # patch -i "${srcdir}/${_patches[-2]}"
- # patch -i "${srcdir}/${_patches[-3]}"
- # patch -i "${srcdir}/${_patches[-4]}"
}
package() {
@@ -75,7 +59,6 @@ package() {
cd "${srcdir}"
install -Dm644 -t "${dest}" "dkms.conf"
- install -Dm644 -t "${dest}/patches" "${_patches[@]}"
cd "repo/fs/ntfs3"
cp -rt "${dest}" *