summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFernando Manfredi2016-04-23 17:01:35 -0300
committerFernando Manfredi2016-04-23 17:01:35 -0300
commit12aadff49ea6bf195c7df1cadb54eb5bc74b9bd0 (patch)
tree6f732eb1924197c944b2774f978c335814480670 /PKGBUILD
parent5f648aa9f933e90fe59829e8bca8e56ff6bb6b8f (diff)
downloadaur-12aadff49ea6bf195c7df1cadb54eb5bc74b9bd0.tar.gz
Make PKGBUILD more sane, fix ntopng@.service
Signed-off-by: Fernando Manfredi <contact@acidhub.click>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 23 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 10f2fdbfab04..ae3a0be46e79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
+# Maintainer: Fernando Manfredi <contact at acidhub.click>
# Contributor: Evan Teitelman <teitelmanevan at gmail dot com>
# Contributor: Ari Mizrahi <codemunchies@gmail.com>
-# Maintainer: CRT <cirkit@kode.email>
+# Contributor: CRT <cirkit@kode.email>
pkgname=ntopng
pkgver=2.2
-pkgrel=1
+pkgrel=2
pkgdesc='The next generation version of the original ntop, a network traffic probe that shows the network usage'
arch=('x86_64' 'i686')
url='http://www.ntop.org/'
license=('GPL3')
-options=('!makeflags')
-depends=('redis' 'libxml2' 'geoip' 'libpcap' 'libnet' 'lua' 'zeromq' 'gd'
- 'gdbm' 'pcre' 'rrdtool' 'psutils')
+depends=('redis' 'geoip')
+makedepends=('glib2' 'automake' 'libtool' 'geoip' 'libpcap' 'wget' 'libxml2' 'sqlite' 'curl' 'libmariadbclient')
source=("http://sourceforge.net/projects/ntop/files/$pkgname/$pkgname-$pkgver.tar.gz"
ntopng@.service)
-md5sums=('c4144be7ff306ebfea1c4368aca066c4'
- 'ca5208df1d80a8b28606d6a64e508902')
+sha256sums=('4fccfc9e9f333addcd3c957b4520c471117bc2df5655d6eabf328c7385fb255e'
+ '034d4fa2a6616a6240edc74e278b96e45730e7acc12d60a7b4458b04906c127b')
build() {
cd "$srcdir/ntopng-$pkgver"
- ./autogen.sh && ./configure --prefix=/usr
+ ./autogen.sh && ./configure --prefix=$pkgdir/usr
make geoip
make
}
@@ -28,28 +28,24 @@ build() {
package() {
cd "$srcdir/ntopng-$pkgver"
- # Base directories.
- install -dm755 "$pkgdir/usr/bin"
- install -dm755 "$pkgdir/usr/share/ntopng"
- install -dm755 "$pkgdir/usr/share/man/man8"
- install -dm755 "$pkgdir/usr/lib/systemd/system"
+ make DESTDIR=$pkgdir install
- # Bin.
- install -m755 ntopng "$pkgdir/usr/share/ntopng"
+ mkdir -p $pkgdir/usr/lib/systemd/system
+ install -m644 "$srcdir/ntopng@.service" "$pkgdir/usr/lib/systemd/system"
- # Man
- install -m755 ntopng.8 "$pkgdir/usr/share/man/man8"
+}
- # Docs.
- cp --no-preserve=ownership -R httpdocs scripts "$pkgdir/usr/share/ntopng"
+post_install() {
- # Systemd service.
- install -m644 "$srcdir/ntopng@.service" "$pkgdir/usr/lib/systemd/system"
+ echo -e "${bold_green}==>${color_reset} ${bold_white}Enable/start your redis.service befose use ntopng!${color_reset}"
+ echo -e " ${bold_blue}#${color_reset} ${bold_white}systemctl ${bold_underline_white}enable${bold_white} redis${color_reset}"
+ echo -e " ${bold_blue}#${color_reset} ${bold_white}systemctl ${bold_underline_white}start${bold_white} redis${color_reset}"
+ echo -e ""
+ echo -e "${bold_green}==>${color_reset} ${bold_white}After enable/start ntopng@ service!${color_reset}"
+ echo -e " ${bold_blue}#${color_reset} ${bold_white}systemctl ${bold_underline_white}enable${bold_white} ntopng@<interface>${color_reset}"
+ echo -e " ${bold_blue}#${color_reset} ${bold_white}systemctl ${bold_underline_white}start${bold_white} ntopng@<interface>${color_reset}"
+ echo -e ""
+ echo -e "Now open ${bold_underline_white}http://localhost:3000/${color_reset} on your favourite browser."
+ echo -e " ${bold_blue}->${color_reset} ${bold_white}More info at https://www.ntop.org/${color_reset}"
- cat > "$pkgdir/usr/bin/ntopng" <<EOF
-#!/bin/sh
-cd /usr/share/ntopng
-./ntopng "\$@"
-EOF
- chmod +x "$pkgdir/usr/bin/ntopng"
}