summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Svoboda2018-08-26 07:43:48 +0200
committerMichal Svoboda2018-08-26 07:43:48 +0200
commit320514a74f4839d8b6c8a2f32790ff16caba9ee7 (patch)
tree8d03b6de0202847d45e4f6654e8ee6ba54e82f07 /PKGBUILD
parent7e5d3ea7cb2523b8fc728793f797bc084fc7959f (diff)
downloadaur-320514a74f4839d8b6c8a2f32790ff16caba9ee7.tar.gz
Fix compilation error in mongoose due to SOCKET redefinition
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d56e070c28e..a7414f46940a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ validpgpkeys=('EFD9413B17293AFDFE6EA6F1402A088DEDF104CB')
pkgname=ntopng
pkgver=3.4
_ndpiver=521afe7e1f340eff5d475b4f0bc6f91ea91c0601
-pkgrel=1
+pkgrel=2
pkgdesc='The next generation version of the original ntop, a network traffic probe that shows the network usage'
arch=('x86_64' 'i686')
url='http://www.ntop.org/'
@@ -16,13 +16,18 @@ depends=('redis' 'geoip' 'libmariadbclient' 'libpcap' 'sqlite')
makedepends=('glib2' 'automake' 'libtool' 'wget' 'curl' 'libxml2')
source=("https://github.com/ntop/$pkgname/archive/$pkgver.tar.gz"
"https://github.com/ntop/nDPI/archive/$_ndpiver.zip"
- "$pkgname@.service")
+ "$pkgname@.service"
+ "fix-mongoose.patch")
sha512sums=('0fc6671b11412d8ecaef45cc3cdd57ab5970af7e08b78181d61657b74bea1a6fed717d00a5c951d2e47ad9c046839be998f39ae0fc5a7b616d5c569f044a12e9'
'fbaa20b0a043d0e39ba9149a5e445765d184892c4385640b445b91a456264ca8365d890eb4a83e76d8f5767b097a5405dc1f2c374adf7e9cfa1211bfc7fd7063'
-'b3d9a2032cce91ee4faf81522a30a2877540b3fc7a0d43f8fe4f01c16efb0b8f6e73cfe26028b3a070296d7156abf511d3e11f93635ca2de8a4d67322b0ade60')
+'b3d9a2032cce91ee4faf81522a30a2877540b3fc7a0d43f8fe4f01c16efb0b8f6e73cfe26028b3a070296d7156abf511d3e11f93635ca2de8a4d67322b0ade60'
+'3652880a2b1899950a8d534d57ffded396e4aa3238831993481d29a527a518ca1210c13c20330281d59c9b1c0287aed1a0312b152dc82e7f75aaaf284310a880'
+)
build() {
+ cd $srcdir
+ patch -p0 < fix-mongoose.patch
cd $srcdir/nDPI-$_ndpiver
./autogen.sh
./configure