summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjohnnybash2023-05-03 20:35:25 +0200
committerjohnnybash2023-05-03 20:35:25 +0200
commit75a0697c7ace5404824cc11a284e93a8da59442f (patch)
tree15bb9ec1b17291bacbd99f7ba8b8e7ac89b3875c /PKGBUILD
parent118306b19f71ad607ce945f32e1b05c4d9efc849 (diff)
downloadaur-75a0697c7ace5404824cc11a284e93a8da59442f.tar.gz
upgpkg: ntopng 5.6-2
add npm stuff
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63cadadaec87..f7f95e6aff1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,13 @@ validpgpkeys=('EFD9413B17293AFDFE6EA6F1402A088DEDF104CB')
pkgname=ntopng
pkgver=5.6
_ndpiver=4.6
-pkgrel=1
+pkgrel=2
pkgdesc='The next generation version of the original ntop, a network traffic probe that shows the network usage'
arch=('x86_64' 'i686')
url='http://www.ntop.org/'
license=('GPL3')
depends=('redis' 'libmariadbclient' 'libpcap' 'sqlite' 'libmaxminddb' 'zeromq' 'rrdtool' 'hiredis')
-makedepends=('glib2' 'automake' 'libtool' 'wget' 'curl' 'libxml2')
+makedepends=('glib2' 'automake' 'libtool' 'wget' 'curl' 'libxml2' 'npm')
install=$pkgname.install
source=("$pkgname-$pkgver.tar.gz::https://github.com/ntop/$pkgname/archive/$pkgver.tar.gz"
"nDPI-$_ndpiver.tar.gz::https://github.com/ntop/nDPI/archive/$_ndpiver.tar.gz"
@@ -37,6 +37,8 @@ build() {
cd $srcdir/$pkgname-$pkgver
./autogen.sh
./configure --prefix=$pkgdir/usr --datadir=/usr/share
+ npm install
+ npm run build
make
}