summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathan2016-07-03 14:51:24 -0600
committerJonathan2016-07-03 14:51:24 -0600
commite8d95c95d4cbf5bc5bc23d3dfa151b7c3cf73db7 (patch)
treecc58d38dcc29879fec48045c26c75a6ce51b51bf /PKGBUILD
parent47bf41326fd77b7fed7426439992c1bbf5e3dfdb (diff)
downloadaur-e8d95c95d4cbf5bc5bc23d3dfa151b7c3cf73db7.tar.gz
fixed all path issues
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dba67cfa2478..b1b6fb957110 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
validpgpkeys=('EFD9413B17293AFDFE6EA6F1402A088DEDF104CB')
pkgname=ntopng
pkgver=2.4
-pkgrel=4
+pkgrel=5
pkgdesc='The next generation version of the original ntop, a network traffic probe that shows the network usage'
arch=('x86_64' 'i686')
url='http://www.ntop.org/'
@@ -23,7 +23,8 @@ sha512sums=('515dd7889ae3aaf2482371bb2c55ab7300cf4207fe07f37029b7529bfb710379c19
build() {
cd ntopng-2.4-stable
- ./autogen.sh && ./configure
+ ./autogen.sh
+ ./configure --prefix=$pkgdir/usr
make geoip
make
}
@@ -31,9 +32,9 @@ build() {
package() {
cd ntopng-2.4-stable
-# make install
- make DESTDIR="$pkgdir/" install
+ make install
+ mv $pkgdir/usr/man $pkgdir/usr/share/
mkdir -p $pkgdir/usr/lib/systemd/system
install -m644 "$srcdir/ntopng@.service" "$pkgdir/usr/lib/systemd/system"