summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGregory Boyce2022-11-23 10:34:31 -0500
committerGregory Boyce2022-11-23 10:34:31 -0500
commit916e9e4853d432325505e06f1218ebd50f534aa1 (patch)
tree6313d63705340e65de0b63e79716140740dfc48b /PKGBUILD
parentfdc94b77249c6eb0cfc4ec9249af5a50724104f2 (diff)
downloadaur-916e9e4853d432325505e06f1218ebd50f534aa1.tar.gz
Switch ntpsec to openssl-1.1
Upstream does not yet build against 3.0, and arch switched their default. We now need to explicitly request openssl-1.1. Thanks to Mirsaltptir for the fix.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06fa32300c48..6a2a8ffc841b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=ntpsec
pkgver=1.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="Security-hardened Network Time Protocol implementation"
arch=('i686' 'x86_64' 'armv7h')
url="https://www.ntpsec.org/"
license=('custom')
-depends=('avahi' 'libbsd' 'python')
+depends=('avahi' 'libbsd' 'python' 'openssl-1.1')
makedepends=('asciidoc' 'pps-tools' 'w3m' 'binutils')
optdepends=('gnuplot: for ntpviz'
'libevent: for ntpdig'
@@ -43,6 +43,10 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
+ export CFLAGS="$CFLAGS -I/usr/include/openssl-1.1"
+ export CXXFLAGS="$CXXFLAGS -I/usr/include/openssl-1.1"
+ export LDFLAGS="$LDFLAGS -L/usr/lib/openssl-1.1/"
+
./waf configure --prefix /usr --sbindir=/usr/bin --enable-debug-gdb \
--refclock=all --enable-doc --htmldir=/usr/share/doc/ntpsec \
--enable-leap-smear