summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTimothy2019-04-20 22:39:47 +0000
committerTimothy2019-04-20 22:39:47 +0000
commit298d538aceeac3a6239f1fea1fc1dbfc97f00f0c (patch)
tree2a3565e89b815b9643ca64e2dc9a73680b699160 /PKGBUILD
parentcf2494fe542e4859b5fdfe18dc445904c670163b (diff)
downloadaur-298d538aceeac3a6239f1fea1fc1dbfc97f00f0c.tar.gz
Further updated PKGBUILD to bring it inline with the base ntpsec package: Installs default config files, sets up system user, adds Arch Linux pools to config and no longer manually installs systemd service
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a39c02483e2..196b0b2164ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=ntpsec-git
pkgver=1.1.3.r478.31d756bcb
-pkgrel=1
+pkgrel=2
pkgdesc="Security-hardened Network Time Protocol implementation (Git HEAD)"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://www.ntpsec.org/"
license=('custom')
-depends=('avahi' 'libseccomp' 'python')
+depends=('avahi' 'libbsd' 'libseccomp' 'python')
makedepends=('asciidoc' 'git' 'pps-tools' 'w3m')
optdepends=('gnuplot: for ntpviz'
'libevent: for ntpdig'
@@ -18,7 +18,8 @@ provides=('ntp' 'ntpsec')
conflicts=('ntp' 'ntpsec')
source=("git+https://gitlab.com/NTPsec/ntpsec.git")
sha512sums=('SKIP')
-validpgpkeys=('DA3FDF774CC70FA64729EC4505D9B371477C7528')
+backup=('etc/ntp.d/default.conf'
+ 'etc/ntp.d/use-pool')
pkgver() {
cd "${pkgname%%-git}"
@@ -28,7 +29,7 @@ pkgver() {
prepare() {
cd "${pkgname%%-git}"
- for patch in ../*.patch; do
+ for patch in ../../*.patch; do
if [ ! -f "$patch" ]; then
break;
else
@@ -56,6 +57,10 @@ package() {
./waf install --destdir="$pkgdir/"
install -Dm 644 etc/logrotate-config.ntpd "$pkgdir/etc/logrotate.d/ntpd"
- install -Dm 644 etc/ntpd.service "$pkgdir/usr/lib/systemd/system/ntpd.service"
install -Dm 644 docs/copyright.text "$pkgdir/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm 644 ../../ntpsec.sysusers "$pkgdir/usr/lib/sysusers.d/ntpsec.conf"
+ install -dm 700 -g 212 -o 212 "$pkgdir/var/lib/ntp"
+ for configfile in etc/ntp.d/*; do
+ install -Dm 644 "$configfile" "$pkgdir/$configfile"
+ done
} \ No newline at end of file