summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTimothy2019-04-20 19:42:15 +0000
committerTimothy2019-04-20 19:42:15 +0000
commitcf2494fe542e4859b5fdfe18dc445904c670163b (patch)
tree0d7d98c1b59c1eef9c8fa19d917ba2501a085980 /PKGBUILD
parentec56e9fd240e72d027d251663b96a492e412d480 (diff)
downloadaur-cf2494fe542e4859b5fdfe18dc445904c670163b.tar.gz
Fixed build issues with current version, now supports ARM platforms as well
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f4b9e3d8342..1a39c02483e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
+# Maintainer: Timothy Brown <sysop@timb.us>
+# Contributor: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=ntpsec-git
-pkgver=0.9.7.r10.d72507311
+pkgver=1.1.3.r478.31d756bcb
pkgrel=1
pkgdesc="Security-hardened Network Time Protocol implementation (Git HEAD)"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://www.ntpsec.org/"
license=('custom')
depends=('avahi' 'libseccomp' 'python')
@@ -38,11 +39,11 @@ prepare() {
build() {
cd "${pkgname%%-git}"
- ./waf configure --prefix=/usr --sbindir=/usr/bin \
+ ./waf configure --prefix=/usr --sbindir=/usr/bin --mandir=/usr/share/man \
--enable-debug-gdb --enable-seccomp --refclock=all \
--enable-doc --htmldir=/usr/share/doc/${pkgname}
./waf build
- a2x -f text docs/copyright.txt
+ a2x -f text docs/copyright.adoc
}
check() {
@@ -57,7 +58,4 @@ package() {
install -Dm 644 etc/logrotate-config.ntpd "$pkgdir/etc/logrotate.d/ntpd"
install -Dm 644 etc/ntpd.service "$pkgdir/usr/lib/systemd/system/ntpd.service"
install -Dm 644 docs/copyright.text "$pkgdir/usr/share/licenses/${pkgname}/COPYING"
-
- # --mandir, it does nothing!
- mv "$pkgdir/usr/man" "$pkgdir/usr/share/man"
-}
+} \ No newline at end of file