summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-09-30 15:50:57 +1300
committercaltlgin2020-09-30 15:50:57 +1300
commitb1fb3c2f142b2ff54f2a8b2c15e24910e790c08a (patch)
tree99241005aaf47ad0558772c1f5788c3937193793 /PKGBUILD
parent8032841c5f4ed07780cdb3b4aa64b15c1962d670 (diff)
downloadaur-b1fb3c2f142b2ff54f2a8b2c15e24910e790c08a.tar.gz
Add "go clean -modcache"
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 244aa0883fdd..a75521614ab1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname='nuclei'
pkgver=2.1.1
pkgrel=1
pkgdesc='Fast tool for configurable targeted scanning based on templates offering massive extensibility and ease of use'
-arch=('x86_64')
+arch=('x86_64' 'armv6h' 'aarch64')
url='https://github.com/projectdiscovery/nuclei'
license=('MIT')
makedepends=('go')
@@ -12,13 +12,17 @@ provides=("${pkgname}")
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
sha256sums=('341a809d7129166045a64db4187576fd23c4304a062b0e1586fee0e0743cc1c0')
+prepare() {
+ export GOPATH="${srcdir}/gopath"
+ go clean -modcache
+}
+
build() {
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- export GOPATH="${srcdir}"
cd "${pkgname}-${pkgver}/v2"
go build -v -o "${pkgname}" ."/cmd/${pkgname}"