summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-06-05 01:53:14 +0800
committerChocobo12023-06-05 01:54:59 +0800
commitc130c4fb75a41e9ca429087543ee8aba0af6b2fa (patch)
tree86d1a628c59fb414d512ca675e2bcb8e9f6ac5a1 /PKGBUILD
parent0e58bf999b377ef353f6c93d687dbd6daebc413c (diff)
downloadaur-nuitka-git.tar.gz
upgpkg: nuitka-git 1.6.r105.gd263e6fd2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa1ec07ecfec..80a2036666fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=nuitka-git
-pkgver=1.5.5.r338.g3c3e8f96d
+pkgver=1.6.r105.gd263e6fd2
pkgrel=1
pkgdesc="A Python compiler"
arch=('any')
url="https://nuitka.net/"
license=('Apache')
-depends=('python')
-makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
+depends=('libxml2' 'python' 'python-setuptools' 'python-wheel')
+makedepends=('git' 'python-build' 'python-installer')
optdepends=('chrpath: for building standalone executables')
provides=("nuitka=$pkgver")
conflicts=('nuitka')
@@ -19,7 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "Nuitka"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {
@@ -38,4 +41,5 @@ package() {
-m installer \
--destdir="$pkgdir" \
dist/*.whl
+ install -Dm644 {Changelog,Developer_Manual,README}.rst -t "$pkgdir/usr/share/doc/nuitka"
}