summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12022-12-27 02:00:56 +0800
committerChocobo12022-12-27 02:00:56 +0800
commitf9c938ae996264d759a8d10e0f052bb0106374f6 (patch)
tree781819454a9fed5a156b50cb81dbbf1a63faaf47 /PKGBUILD
parent5752fa7f54529628ec693100a4b83405b6f41952 (diff)
downloadaur-f9c938ae996264d759a8d10e0f052bb0106374f6.tar.gz
upgpkg: nuitka-git 1.3.2.r7.g9a24f7a54-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 16 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 69e7f7bece5d..644375352ad3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=nuitka-git
-pkgver=0.6.3.1.r137.g99b496e6
+pkgver=1.3.2.r7.g9a24f7a54
pkgrel=1
pkgdesc="A Python compiler"
arch=('any')
url="https://nuitka.net/"
license=('apache')
depends=('python')
-makedepends=('git' 'python-setuptools')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
optdepends=('chrpath: for building standalone executables')
-provides=('nuitka')
+provides=("nuitka=$pkgver")
conflicts=('nuitka')
source=("git+https://github.com/Nuitka/Nuitka.git")
sha256sums=('SKIP')
@@ -22,10 +22,20 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd "Nuitka"
+
+ python \
+ -m build \
+ --wheel \
+ --no-isolation
+}
+
package() {
cd "Nuitka"
- python "setup.py" install \
- --optimize 1 \
- --root "$pkgdir"
+ python \
+ -m installer \
+ --destdir="$pkgdir" \
+ dist/*.whl
}