summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Goldsmith2016-04-20 00:19:55 -0400
committerAdam Goldsmith2016-04-20 00:19:55 -0400
commit79f5bff72ac1e1b2d0faa3e8c4dc015b0d63ec93 (patch)
tree072a8197fbc2fc21f0cf0ee38064fe4858007186 /PKGBUILD
parentf774a5cec5c07169b790f916beba869d604666e5 (diff)
downloadaur-79f5bff72ac1e1b2d0faa3e8c4dc015b0d63ec93.tar.gz
Convert to dark blue colors/name
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 22 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7314136c3c2..6400f9a0f6e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,32 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+# Based on numix-themes-git
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Diego <cdprincipe@gmail.com>
-pkgname=numix-themes-git
-pkgver=2.5.1.r98.5cccc5b
-pkgrel=2
-pkgdesc='A flat and light theme with a modern look (GNOME, Openbox, Unity, Xfce)'
+pkgname=numix-themes-darkblue-git
+pkgver=2.5.1.r200.a0736e4
+pkgrel=1
+pkgdesc='A flat and light theme with a modern look (GNOME, Openbox, Unity, Xfce) (Dark Blue Variant)'
arch=('any')
url='http://numixproject.org/'
license=('GPL3')
makedepends=('git' 'glib2' 'ruby-sass')
optdepends=('gtk-engine-murrine: GTK2 theme engine')
-provides=('numix-themes')
-conflicts=('numix-themes')
-source=('numix-themes::git+https://github.com/shimmerproject/Numix.git')
-md5sums=('SKIP')
+provides=('numix-themes-darkblue')
+conflicts=('numix-themes-darkblue')
+source=('numix-themes::git+https://github.com/shimmerproject/Numix.git'
+ 'dark_colors.patch')
+md5sums=('SKIP'
+ 'b5e966fada97b870f5cd38d07afb609a')
+
+prepare() {
+ cd numix-themes/
+
+ patch -Np1 -i ../dark_colors.patch
+ ln -srf gtk-3.0/gtk{-dark,}.css
+ ln -srf gtk-3.20/gtk{-dark,}.css
+}
pkgver() {
cd numix-themes
@@ -30,7 +43,7 @@ build() {
package() {
cd numix-themes
- make DESTDIR="${pkgdir}" install
+ make INSTALL_DIR="${pkgdir}/usr/share/themes/Numix-DarkBlue" install
}
# vim: ts=2 sw=2 et: