summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2015-09-18 11:38:08 +0200
committerMaxime Gauduin2015-09-18 11:38:08 +0200
commitb9c81dc4061a7876550eed1292b94273b83a000e (patch)
tree691420046908c8b9368d95a8d92d4145f0d4de35 /PKGBUILD
parent975ca885f32041b6bbfd5c274ef8a626288fcd85 (diff)
downloadaur-b9c81dc4061a7876550eed1292b94273b83a000e.tar.gz
numix-themes-git 2.5.1.r98.5cccc5b-1
Update for SASS
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b072e3921c08..9a3d34bd6f9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
# Contributor: Diego <cdprincipe@gmail.com>
pkgname=numix-themes-git
-pkgver=2.5.1.r11.c05a9fd
+pkgver=2.5.1.r98.5cccc5b
pkgrel=1
pkgdesc='A flat and light theme with a modern look (GNOME, Openbox, Unity, Xfce)'
arch=('any')
url='http://numixproject.org/'
license=('GPL3')
-depends=('gtk-engine-murrine')
-makedepends=('git')
+makedepends=('git' 'ruby-sass')
provides=('numix-themes')
conflicts=('numix-themes')
source=('numix-themes::git+https://github.com/shimmerproject/Numix.git')
@@ -18,16 +17,19 @@ md5sums=('SKIP')
pkgver() {
cd numix-themes
- printf "%s" "$(git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./')"
- #printf "2.5.1.r%s.%s" "$(git rev-list --count v2.4..HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --tags | sed 's/^v//; s/-/.r/; s/-g/./'
+}
+
+build() {
+ cd numix-themes
+
+ make
}
package() {
cd numix-themes
- install -dm 755 "${pkgdir}"/usr/share/themes/Numix
- rm -rf .git .gitignore CREDITS LICENSE README.md
- cp -dr --no-preserve='ownership' * "${pkgdir}"/usr/share/themes/Numix/
+ make DESTDIR="${pkgdir}" install
}
# vim: ts=2 sw=2 et: