summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStorm Dragon2019-11-25 16:34:37 -0500
committerStorm Dragon2019-11-25 16:34:37 -0500
commit9236517fbe8dcbe24fa4b616c37a2dcd690ea498 (patch)
tree3efdd7226a458b87df12b698640a9b636cb0705e /PKGBUILD
downloadaur-9236517fbe8dcbe24fa4b616c37a2dcd690ea498.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c455883c83f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+_pkgname="numnastics"
+pkgname="${_pkgname}-git"
+pkgver=r2.3d956cc
+pkgrel=1
+pkgdesc="A number puzzle audio game"
+arch=('any')
+url="https://gitlab.com/stormdragon2976/numnastics"
+license=('GPL3')
+depends=('python' 'python-pygame' 'python-requests' 'python-xdg')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://gitlab.com/stormdragon2976/numnastics.git"
+ "$_pkgname.desktop"
+ "$_pkgname.sh")
+sha512sums=('SKIP'
+ 'b45168181aeeca72a8d0e74cf6eff6dd2e7511431f8cf9157b9804445145e170c98328a7216ea27d9a02809bba328935e0f4fe95e519648e8217453749c42bbe'
+ '5e7686884116fdca9a58508dee891b6285e1ad7755a505c199024036fad3428514d16ccef3e96ff6803a45d67a7ca618000a3c1733c07028a67ad804a8fbc123')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+ install -d "$pkgdir/opt/numnastics"
+ cp -a * "$pkgdir/opt/numnastics"
+
+ install -Dm755 "$srcdir/$_pkgname.sh" "$pkgdir/usr/bin/$_pkgname"
+
+ install -Dm644 "$srcdir/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}
+
+# vim:set ts=2 sw=2 et: