summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBhoppi Chaw2018-12-12 00:41:36 +0800
committerBhoppi Chaw2018-12-12 00:41:36 +0800
commit15962df540ac12c960880a165ce76bebdb6df65e (patch)
tree37cf518b09db3b05fc48c068e5fb3c3b376f33b4 /PKGBUILD
parent42544337ab2c9715cac14b44cc94658d17c8aee1 (diff)
downloadaur-15962df540ac12c960880a165ce76bebdb6df65e.tar.gz
change source links; precompile python scripts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6462abe7fc80..b398657cf0c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,26 @@
pkgname=nutstore
pkgver=4.1.4
-pkgrel=2
+pkgrel=3
pkgdesc='a cloud service that lets you sync and share files anywhere.'
arch=(x86_64)
-url='https://jianguoyun.com/'
+url='https://www.jianguoyun.com/'
license=(custom)
depends=(libappindicator-gtk3 libnotify python-gobject)
optdepends=('nautilus-nutstore: Nautilus plugin')
source=(nutstore license)
+source_x86_64=("https://www.jianguoyun.com/static/exe/st/$pkgver/nutstore_client-$pkgver-linux-x64-public.tar.gz")
+#source_i686=("https://www.jianguoyun.com/static/exe/st/$pkgver/nutstore_client-$pkgver-linux-x86-public.tar.gz")
sha256sums=('3091740b20ddd31ba4407b8daba1077c4677040cdc47bccfab2f7f3947676384'
'f3d2861ff48f2d193a4eced23a02b4eba9fab4c1d3f727e934ed7c59f38f0f7e')
-source_x86_64=('https://www.jianguoyun.com/static/exe/installer/nutstore_linux_dist_x64.tar.gz')
sha256sums_x86_64=('b0ec672174b7f3d100d41bb6ab8768d45cfb36aef47b5e80a3560bec8842bf84')
-#source_i686=('https://www.jianguoyun.com/static/exe/installer/nutstore_linux_dist_x86.tar.gz')
-#sha256sums_i686=('4c876e0e906f8a168549718d43d59a7a0492771275c5dd20f564998fdb3953d1')
build() {
cd $srcdir/gnome-config
sed -i '/Exec=/s|~/\.nutstore/dist/bin/nutstore-pydaemon.py|/usr/bin/nutstore|' menu/nutstore-menu.desktop
sed -i '/Exec=/s|~/\.nutstore/dist|/opt/nutstore|' autostart/nutstore-daemon.desktop
+ cd $srcdir/bin
+ python -m compileall .
}
package() {