diff options
author | Ben Westover | 2022-01-11 09:59:01 -0500 |
---|---|---|
committer | Ben Westover | 2022-01-11 09:59:01 -0500 |
commit | 3c3a70f8858319b182caba7208813a1d36acd3af (patch) | |
tree | 9bae321ddbbdd2bf8af565fe43f33681df2bc3ed /PKGBUILD | |
parent | d0e36e649f309eba50f90e71beefe678de9c047d (diff) | |
download | aur-3c3a70f8858319b182caba7208813a1d36acd3af.tar.gz |
Fix wx issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 11 |
1 files changed, 9 insertions, 2 deletions
@@ -2,17 +2,20 @@ pkgname='nuxhash-git' pkgver=v1.0.0b2.r33.g33e9a09 -pkgrel=3 +pkgrel=4 pkgdesc="A NiceHash cryptocurrency mining client for Linux." arch=('x86_64') url="https://github.com/YoRyan/nuxhash" license=('GPL3') depends=('python' 'python-requests' 'curl' 'nvidia' 'opencl-nvidia' 'cuda') makedepends=('python-setuptools') -optdepends=('python-wxpython: GUI support') +optdepends=('python-wxpython: GUI support' + 'python-pypubsub: GUI support') source=("git+https://github.com/YoRyan/nuxhash.git" + "fix-wx-issues.patch" "nuxhash-gui.desktop") sha256sums=('SKIP' + '0c3b44fdb4b44098cfbcd49df553b3325205faae0902f3cf8b1d223720a0876a' '779c28c990c97b6c6fb2b2ad1cf84ff99dcdf5c1b72f034750994fdc8a645055') pkgver() { @@ -20,6 +23,10 @@ pkgver() { git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' } +prepare() { + patch -p1 < fix-wx-issues.patch +} + package() { cd nuxhash python3 setup.py install --optimize=1 --root "$pkgdir" |