summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBen Westover2022-01-11 14:20:37 -0500
committerBen Westover2022-01-11 14:20:37 -0500
commitf95bcfa6918e4e649be500471e63a32080d3d8bb (patch)
tree06cc2e902ce00699c12ec53dd78538f471e7f826 /PKGBUILD
parent3c3a70f8858319b182caba7208813a1d36acd3af (diff)
downloadaur-f95bcfa6918e4e649be500471e63a32080d3d8bb.tar.gz
Split GUI support into different package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 5 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7dcd170f0b3..a2b196c02447 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,23 @@
pkgname='nuxhash-git'
pkgver=v1.0.0b2.r33.g33e9a09
-pkgrel=4
+pkgrel=5
pkgdesc="A NiceHash cryptocurrency mining client for Linux."
arch=('x86_64')
url="https://github.com/YoRyan/nuxhash"
license=('GPL3')
depends=('python' 'python-requests' 'curl' 'nvidia' 'opencl-nvidia' 'cuda')
makedepends=('python-setuptools')
-optdepends=('python-wxpython: GUI support'
- 'python-pypubsub: GUI support')
-source=("git+https://github.com/YoRyan/nuxhash.git"
- "fix-wx-issues.patch"
- "nuxhash-gui.desktop")
-sha256sums=('SKIP'
- '0c3b44fdb4b44098cfbcd49df553b3325205faae0902f3cf8b1d223720a0876a'
- '779c28c990c97b6c6fb2b2ad1cf84ff99dcdf5c1b72f034750994fdc8a645055')
+source=("git+https://github.com/YoRyan/nuxhash.git")
+sha256sums=('SKIP')
+install=nuxhash-git.install
pkgver() {
cd nuxhash
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- patch -p1 < fix-wx-issues.patch
-}
-
package() {
cd nuxhash
- python3 setup.py install --optimize=1 --root "$pkgdir"
- install -Dm644 nuxhash/gui/icons/nuxhash.svg "$pkgdir/usr/share/pixmaps/nuxhash.svg"
- install -Dm644 ../nuxhash-gui.desktop "$pkgdir/usr/share/applications/nuxhash-gui.desktop"
+ python setup.py install --optimize=1 --root "$pkgdir"
}