summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2018-06-01 17:15:21 +0100
committerAdrian Perez de Castro2018-06-01 17:15:21 +0100
commita06fd99abeeeaa4721d890ff824203d4f2ca7748 (patch)
tree180fa2f24e04d1dc469c0422af150d500556294a /PKGBUILD
downloadaur-a06fd99abeeeaa4721d890ff824203d4f2ca7748.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48852f9bdf1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+pkgdesc='VHDL compiler and simulator'
+pkgname=nvc
+pkgver=1.3.1
+pkgrel=1
+url='https://github.com/nickg/nvc'
+license=('GPL3')
+depends=('llvm' 'tcl' 'libelf')
+conflicts=('nvc-git')
+arch=('x86_64' 'i686')
+makedepends=('pkgconfig' 'make' 'flex' 'check')
+
+_vital_url='https://raw.githubusercontent.com/tgingold/ghdl/master/libraries/vital2000'
+
+source=("${url}/releases/download/r${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "https://standards.ieee.org/downloads/1076.2-1996_downloads.zip"
+ "${_vital_url}/timing_p.vhdl"
+ "${_vital_url}/timing_b.vhdl"
+ "${_vital_url}/prmtvs_p.vhdl"
+ "${_vital_url}/prmtvs_b.vhdl"
+ "${_vital_url}/memory_p.vhdl"
+ "${_vital_url}/memory_b.vhdl")
+
+sha512sums=('5f535d0dd96119d41604dbd604f9a4d99d6afd47fd582d3522baf2ca40029ac71690ca32ef3b1963335cff1174d76dbf948410fc3e45c704caca83b1ff44415d'
+ '428ebaaa02eb25240569c90e907828ce87e7a18e3a61d9809dda8ecc0bb46a59d0d6c15e625cc0d8e92b26d37dae3be68b480acc77326c07b763fd986bd8e563'
+ 'bdc38f3f3b5f9b0e572277e8a984361fec7fc877db7ee819bfe4cc9de0f101e53d52472b39b0d3b2c931b50af942378002481dff8e4b99732823ec8d364abe12'
+ 'affb483b7a2c2cf8e99619696289f578ff0c28b980d3807d9d3b815874af94ccaeb92adb9415409256b1ddd399cc64eefa52648a42913259af275eea871547b3'
+ '741b95985a4a98427d459dba141eebca2fbc3b1a1a3c1cf237d5b6e9d5e12417a9568b38f98049ffdaaa6d6ea11604a869a53a1b66956d61c6487e53b719b309'
+ 'f0f604bb5bd1e0a8a2a15a4ac5180948e35be30f1479646ddf52803100dcf2c3b8546722f23a81934d006be1b25b44a7fd76ba3dbc8a1ad670560b405f53a0f2'
+ '7358582b3f3877c8492b8cce1bc238dc6ef60818cdfe7e4a2ed5cb50ffe74c81221b7e473e59504328d2583c7e555457be50faf9238402bce1f6236586891c51'
+ '41d9d4862db13cf741fa857ca085ba3fa3596d61eb8276effcfe8b9b7359479670c83fe525a98b595f523506c821b2ed3569fa72df5f62a6f83f7805436b02bf')
+
+prepare () {
+ cd "${pkgname}-${pkgver}/lib/ieee"
+ cp -v "${srcdir}"/*.vhdl "${srcdir}/1076.2-1996_downloads"/*.vhdl .
+
+ sed -i -e '119,120 s/^--/ /' -e '89 s/^--/ /' \
+ std_logic_1164.vhdl
+
+ sed -i -e '367,382 s/^--/ /' -e '384,399 s/^--/ /' -e '165,168 s/^--/ /' \
+ std_logic_1164-body.vhdl
+}
+
+build () {
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+# The source distribution is missing VHDL source files which are
+# needed to run the test suite.
+#
+# check () {
+# cd "${pkgname}-${pkgver}"
+# make check
+# }
+
+package () {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -m 644 -D src/vhpi/vhpi_user.h "${pkgdir}/usr/include/vhpi_user.h"
+}