summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2023-06-28 23:50:03 +0300
committerAdrian Perez de Castro2023-06-28 23:50:03 +0300
commitf22485d0295e7b5779379ab731dfd644222ae15f (patch)
tree517e86a088238caa19273ed8236bf0d96a36ee95 /PKGBUILD
parent5ccc1f2ba5878835d368f3cb1b6daeef3361baa8 (diff)
downloadaur-f22485d0295e7b5779379ab731dfd644222ae15f.tar.gz
Bump to version 1.9.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9cf69fa13ab4..2839612f6f58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
pkgdesc='VHDL compiler and simulator'
pkgname=nvc
-pkgver=1.7.2
-pkgrel=2
+pkgver=1.9.2
+pkgrel=1
url=https://www.nickg.me.uk/nvc
license=(GPL3)
conflicts=(nvc-git)
arch=(x86_64 i686)
-depends=(libelf llvm-libs ncurses)
+depends=(libelf llvm-libs ncurses zstd)
makedepends=(pkgconfig make flex check llvm tcl automake autoconf)
optdepends=('ruby: for the scripts to download and install VHDL libraries')
source=("${url%/nvc}/files/${pkgname}-${pkgver%.0}.tar.gz")
-b2sums=('b885d1fed19ad1cba51967557bf26a14227deb0ea8946a7bfdca4c301031d18e0fc92fdbb26413c451a55e3de04766cebab8e41a5d9445f5ec95c880b1351d1c')
+b2sums=('0da9116aa9fdffa674cc784832ef0d479da70b14dc283a7dac8df7ea9068025f65d4fbeca5f05e62db4b6d0bf7a2bc5c579104f78f75d41c14a27acc65e3c642')
build () {
cd "${pkgname}-${pkgver%.0}"
@@ -26,10 +26,12 @@ build () {
../configure \
--prefix=/usr \
--disable-dependency-tracking \
- --enable-vhpi \
+ --enable-jit \
+ --enable-verilog \
--enable-vital \
--enable-lto \
--with-llvm=/usr/bin/llvm-config \
+ --with-bash-completion=/usr/share/bash-completion \
--with-ncurses
make && make bootstrap
}