summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilydjwg2017-07-10 12:58:22 +0800
committerlilydjwg2017-07-10 12:58:22 +0800
commit4abe85d8c71eeaeccb6018959b55f4be33f94d3e (patch)
tree28a815bbd8d6ce50a177bfa374733343c42ae805 /PKGBUILD
parent2855af5c66a3caa82d792f4ba6779f49370177eb (diff)
downloadaur-4abe85d8c71eeaeccb6018959b55f4be33f94d3e.tar.gz
fix version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a401f270b05f..fcceb550106e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Co-maintainer: lilydjwg <lilydjwg@gmail.com>
pkgname=nvchecker-git
-pkgver=v0.4.4.r31.g189847f
+pkgver=0.5dev.4
pkgrel=1
pkgdesc="a tool for checking if a new version of some software has been released."
arch=('any')
@@ -23,7 +23,7 @@ _gitroot=nvchecker
pkgver() {
cd "$srcdir/$_gitroot"
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ echo $(awk '$1 == "__version__" { gsub(/\x27/, "", $3); print $3 }' nvchecker/__init__.py).$(git describe --long | cut -d. -f2)
}
build() {