summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNorbert Preining2024-10-27 10:38:39 +0900
committerNorbert Preining2024-10-27 10:38:39 +0900
commit9302a5a95c959ae6f35d4773b0323f0a4e392be2 (patch)
treef0e948476fd3f5d33fd87897bf48969cdf882df5 /PKGBUILD
parentad53d78f1174f200422c5c3e802776bceb2d8b9b (diff)
downloadaur-9302a5a95c959ae6f35d4773b0323f0a4e392be2.tar.gz
Compile against system provided libdovi
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 087031b1082b..5aadc4eab1e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,28 @@
_UpstreamPkgName=NVEnc
pkgname=${_UpstreamPkgName,,}
pkgver=7.71
-pkgrel=1
+pkgrel=2
pkgdesc="NVIDIA Video Codec based command line encoder"
arch=('x86_64')
url="https://github.com/rigaya/$_UpstreamPkgName"
license=('MIT')
# While cuda and nvidia are not strictly necessary accoring the ldd
# the program will not work at all without them installed.
-depends=('cuda>=10' 'ffmpeg' 'libass' 'vapoursynth')
+depends=('cuda>=10' 'ffmpeg' 'libass' 'vapoursynth' 'libdovi')
makedepends=('git' 'gcc13')
source=(git+${url}.git#tag=${pkgver}
git+https://github.com/tplgy/cppcodec.git
- ldflags-adjustments.patch)
+ ldflags-adjustments.patch
+ support-system-libdovi.patch)
sha256sums=('6499bdaaeb3275426b0824e10b2b93c6b7d6ece70ef8c61c4fb8c62a31c069d3'
'SKIP'
- '9032a642a66219efe9413cee1cb371ca3f46de254c6b50f3605df3f385ec53a5')
+ '9032a642a66219efe9413cee1cb371ca3f46de254c6b50f3605df3f385ec53a5'
+ '89141a2e80edc6fa11de6d116d9d4577c5b8864ebcf59fcf68ddbde34c369a6b')
prepare() {
cd $_UpstreamPkgName
patch --forward --strip=1 --input="${srcdir}/ldflags-adjustments.patch"
+ patch --forward --strip=0 --input="${srcdir}/support-system-libdovi.patch"
}
build() {