summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2017-02-24 15:41:24 -0500
committergraysky2017-02-24 15:41:24 -0500
commitb1b7204cc4ece92fd46efe87e050348c1b887f65 (patch)
treea1c96530d9e9d27b34c21d632b6be0d278dd6a7c /PKGBUILD
parentff13983fb44d6dfb92189b0e24e1ec9a330325ae (diff)
downloadaur-b1b7204cc4ece92fd46efe87e050348c1b887f65.tar.gz
Update to 304.135-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7270dc24b1ae..f06da0b6f159 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Thomas Baechler <thomas@archlinux.org>
pkgname=nvidia-304xx-ck
-pkgver=304.134
+pkgver=304.135
_extramodules=extramodules-4.9-ck
-pkgrel=7
+pkgrel=1
_pkgdesc="NVIDIA drivers for linux-ck, 304xx legacy branch."
pkgdesc="$_pkgdesc"
arch=('i686' 'x86_64')
@@ -18,25 +18,18 @@ conflicts=('nvidia-340xx-ck' 'nvidia-ck')
license=('custom')
install=readme.install
options=(!strip)
-source=('disable-mtrr.patch'
-'unfuck_kernel_4.9_series.patch'
-)
+source=('unfuck_kernel_4.9_series.patch')
source_i686+=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64+=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-sha256sums=('4263cf19e49acb33ad2641db674ea1eccb71a573300b345636fe99c87fcbdc71'
- 'c2e697e56ac1bf418052a24c16c77d5149474b661227c494ce9949d050c2d9c5')
-sha256sums_i686=('84f7891af131bb9f9a8a34401dfef4288218019406dfa4ae57b6d52b14e81c9d')
-sha256sums_x86_64=('42213765cd28078314657d3c1ba382584f09e5e57598240596021f4f76c0c443')
+sha256sums=('c2e697e56ac1bf418052a24c16c77d5149474b661227c494ce9949d050c2d9c5')
+sha256sums_i686=('5cb0a191ddca7b4c72b3c26cd57b7d719878ce628d24b5b026a0e5c8d3a00d93')
+sha256sums_x86_64=('352f4a4d5ef692b26383e2cf9ec866f6973f905d53eb6bc9f2161b6ba2afae5a')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
-
- # FS#47092
- #(cd kernel; patch -p1 --no-backup-if-mismatch -i "$srcdir"/disable-mtrr.patch)
- patch -Np1 -i "$srcdir/disable-mtrr.patch"
# FS#52734
patch -Np1 -i "$srcdir/unfuck_kernel_4.9_series.patch"