summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2017-01-27 15:22:23 -0500
committergraysky2017-01-27 15:22:23 -0500
commitc443f5f1d9ad48ede3d2ec707670a29ea5abdaa2 (patch)
tree5f85d3d2110c769140b997db88939041bcf1eb79 /PKGBUILD
parent84b9b1429fab5551f36cf67658e3847cb6b9f805 (diff)
downloadaur-c443f5f1d9ad48ede3d2ec707670a29ea5abdaa2.tar.gz
Update to 304.134-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 77cc78c9af58..8facf69a6d65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=nvidia-304xx-ck
pkgver=304.134
_extramodules=extramodules-4.9-ck
-pkgrel=3
+pkgrel=4
_pkgdesc="NVIDIA drivers for linux-ck, 304xx legacy branch."
pkgdesc="$_pkgdesc"
arch=('i686' 'x86_64')
@@ -19,10 +19,12 @@ license=('custom')
install=readme.install
options=(!strip)
source=('disable-mtrr.patch'
+'unfuck_kernel_4.9_series.patch'
)
source_i686+=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64+=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-sha256sums=('cbaa0c4e4f30d993958c079a22e0346970f99d4fda9d12379777bb16ab3306c9')
+sha256sums=('4263cf19e49acb33ad2641db674ea1eccb71a573300b345636fe99c87fcbdc71'
+ 'c2e697e56ac1bf418052a24c16c77d5149474b661227c494ce9949d050c2d9c5')
sha256sums_i686=('84f7891af131bb9f9a8a34401dfef4288218019406dfa4ae57b6d52b14e81c9d')
sha256sums_x86_64=('42213765cd28078314657d3c1ba382584f09e5e57598240596021f4f76c0c443')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
@@ -32,8 +34,12 @@ prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
- # FS#47092
- (cd kernel; patch -p1 --no-backup-if-mismatch -i "$srcdir"/disable-mtrr.patch)
+ # FS#47092
+ #(cd kernel; patch -p1 --no-backup-if-mismatch -i "$srcdir"/disable-mtrr.patch)
+ patch -Np1 -i "$srcdir/disable-mtrr.patch"
+
+ # FS#52734
+ patch -Np1 -i "$srcdir/unfuck_kernel_4.9_series.patch"
}
build() {