summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2017-02-27 17:41:50 -0500
committergraysky2017-02-27 17:41:50 -0500
commitc67a0e287a9b4953f92773aac986d2b699fd00cd (patch)
tree4397029cd3e29f2e15450ad69aec08645e7b03b6 /PKGBUILD
parentb1b7204cc4ece92fd46efe87e050348c1b887f65 (diff)
downloadaur-c67a0e287a9b4953f92773aac986d2b699fd00cd.tar.gz
Update to 304.135-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f06da0b6f159..76155760e6da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,24 @@
pkgname=nvidia-304xx-ck
pkgver=304.135
-_extramodules=extramodules-4.9-ck
-pkgrel=1
+_extramodules=extramodules-4.10-ck
+pkgrel=2
_pkgdesc="NVIDIA drivers for linux-ck, 304xx legacy branch."
pkgdesc="$_pkgdesc"
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
-depends=('linux-ck>=4.9' 'linux-ck<4.10' 'libgl' "nvidia-304xx-utils=${pkgver}")
-makedepends=('linux-ck-headers>=4.9' 'linux-ck-headers<4.10' 'nvidia-304xx-libgl')
+depends=('linux-ck>=4.10' 'linux-ck<4.11' 'libgl' "nvidia-304xx-utils=${pkgver}")
+makedepends=('linux-ck-headers>=4.10' 'linux-ck-headers<4.11' 'nvidia-304xx-libgl')
conflicts=('nvidia-340xx-ck' 'nvidia-ck')
#groups=('ck-generic')
#replaces=()
license=('custom')
install=readme.install
options=(!strip)
-source=('unfuck_kernel_4.9_series.patch')
+source=('kernel_4.10.patch')
source_i686+=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64+=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-sha256sums=('c2e697e56ac1bf418052a24c16c77d5149474b661227c494ce9949d050c2d9c5')
+sha256sums=('7d35792528cade28232a2a0f582d36975c271de6fe99a6f3a4046b9637b9739a')
sha256sums_i686=('5cb0a191ddca7b4c72b3c26cd57b7d719878ce628d24b5b026a0e5c8d3a00d93')
sha256sums_x86_64=('352f4a4d5ef692b26383e2cf9ec866f6973f905d53eb6bc9f2161b6ba2afae5a')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
@@ -31,8 +31,8 @@ prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
- # FS#52734
- patch -Np1 -i "$srcdir/unfuck_kernel_4.9_series.patch"
+ # patches here
+ patch -Np1 --no-backup-if-mismatch -i ../kernel_4.10.patch
}
build() {