summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsirlucjan2016-09-27 22:24:25 +0200
committersirlucjan2016-09-27 22:24:25 +0200
commit8caf9d25018d16a483d148a573ca20bb3389838f (patch)
treeb2994e7284df3d688f65cc46bb2d3e5cc4301c81 /PKGBUILD
parent2bf4b631035d5445f96f810bd560296c6e87186d (diff)
downloadaur-8caf9d25018d16a483d148a573ca20bb3389838f.tar.gz
Bump to 340.98
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b142220e1b8..eb0dea11b15d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Felix Yan <felixonmars@gmail.com>
pkgname=nvidia-340xx-lqx
-pkgver=340.96
+pkgver=340.98
_extramodules=extramodules-4.7-lqx
-pkgrel=6
+pkgrel=1
_pkgdesc="NVIDIA 340xx drivers for linux-lqx."
pkgdesc="$_pkgdesc"
arch=('i686' 'x86_64')
@@ -16,12 +16,11 @@ conflicts=('nvidia-lqx' 'nvidia-304xx-lqx')
license=('custom')
install=nvidia-340xx-lqx.install
options=(!strip)
-source=('linux-4.6.patch')
-source_i686+=("ftp://download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
-source_x86_64+=("ftp://download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-md5sums=('1f2baa65fd351ae7a2fc3dfd71ffcbfe')
-md5sums_i686=('cb64b165b638671bcdc75bcf297b8d90')
-md5sums_x86_64=('7bdbcee13bade63227933d9217571882')
+source_i686+=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
+source_x86_64+=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
+md5sums_i686=('3ccb023eec137cbee0d2035c288b6bbe')
+md5sums_x86_64=('e8d1292d8d002a15e10ea349151fa8f2')
+
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
@@ -29,7 +28,7 @@ md5sums_x86_64=('7bdbcee13bade63227933d9217571882')
prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
- patch -p1 --no-backup-if-mismatch -i ../linux-4.6.patch
+
cp -a kernel kernel-dkms
}