summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzeakz2025-01-18 00:26:51 -0800
committerzeakz2025-01-18 00:26:51 -0800
commit4d18382149609667389faa00f3cf6cfa3135eac9 (patch)
tree94b3712618f844d8e6193cf87919fa1219fb2e5a /PKGBUILD
parent97c777c2b8765acf892e438bb0c417cf3492c910 (diff)
downloadaur-4d18382149609667389faa00f3cf6cfa3135eac9.tar.gz
fixed compilation issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 7 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1efc99bc50ee..e3be645cc2d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,7 @@ makedepends=('git')
install=${pkgname}.install
source=("git+https://github.com/Frogging-Family/nvidia-all.git")
+
sha256sums=('SKIP')
pkgver() {
@@ -20,34 +21,19 @@ pkgver() {
prepare() {
cd "${srcdir}/nvidia-all"
- # Ensure we have a clean build environment
- if [[ -f "PKGBUILD" ]]; then
- cp PKGBUILD "${srcdir}/nvidia-all-PKGBUILD"
- cp -r ./patches "${srcdir}/" 2>/dev/null || true
- cp -r ./*.install "${srcdir}/" 2>/dev/null || true
- fi
+ # No need to copy files manually, just ensure the repo is up to date
+ git pull --rebase || true
}
build() {
- # Create a clean build directory
- cd "${srcdir}"
- rm -rf build
- mkdir -p build
- cd build
-
- # Copy the necessary files
- cp "${srcdir}/nvidia-all-PKGBUILD" PKGBUILD
- [[ -d "${srcdir}/patches" ]] && cp -r "${srcdir}/patches" .
- cp -r "${srcdir}"/*.install . 2>/dev/null || true
-
- # Build the package without installing
+ cd "${srcdir}/nvidia-all"
+ # Simply run makepkg in the directory where the PKGBUILD is
makepkg -f
}
package() {
- cd "${srcdir}/build"
-
- # Create package directory structure
+ cd "${srcdir}/nvidia-all"
+ # Package the resulting files after build
install -dm755 "${pkgdir}/usr/share/${pkgname}"
# Copy the built packages and build files