summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDet2015-10-13 23:21:14 +0300
committerDet2015-10-13 23:21:14 +0300
commita6b06780a981f6025ef152045f92e60ce6ad0ef3 (patch)
tree2cc5ec169ed4c971d98c9d0b6217aa7f3e70f75c /PKGBUILD
parent566a4744cd696e44ae207cb23af28ca0ee92a850 (diff)
downloadaur-a6b06780a981f6025ef152045f92e60ce6ad0ef3.tar.gz
Upgpkg: 358.09
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 54b01de9817a..72156bfd84a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Based on nvidia-beta: https://aur.archlinux.org/packages/nvidia-beta/
pkgname=nvidia-beta-all
-pkgver=355.11
+pkgver=358.09
pkgrel=1
pkgdesc="NVIDIA drivers for all kernels on the system (beta)"
arch=('i686' 'x86_64')
@@ -25,8 +25,8 @@ esac
# Source
source_i686=("http://us.download.nvidia.com/XFree86/Linux-x86/$pkgver/NVIDIA-Linux-x86-$pkgver.run")
source_x86_64=("http://us.download.nvidia.com/XFree86/Linux-x86_64/$pkgver/NVIDIA-Linux-x86_64-$pkgver-no-compat32.run")
-md5sums_i686=('16d143ccafe99328a2ca8e5a396fd4bc')
-md5sums_x86_64=('30133d89690f4683c4e289ec6c0247dc')
+md5sums_i686=('644159cc26ec16943857c722dbe2a370')
+md5sums_x86_64=('321e1de2a7c4761ae6d59455bc93aca9')
# Auto-detect patches (e.g. nvidia-linux-4.1.patch)
for _patch in $(ls "$startdir"/*.patch 2>/dev/null); do
@@ -88,14 +88,22 @@ package() {
# Install
install -Dm644 $_pkg/kernel-$_extramodules/nvidia.ko \
- "$pkgdir"/$_path/nvidia.ko
+ "$pkgdir"/$_path/nvidia.ko
# Install UVM Module: http://devblogs.nvidia.com/parallelforall/unified-memory-in-cuda-6/
if [[ $CARCH = x86_64 ]]; then
install -Dm644 $_pkg/kernel-$_extramodules/nvidia-uvm.ko \
- "$pkgdir/$_path/nvidia-uvm.ko"
+ "$pkgdir"/$_path/nvidia-uvm.ko
fi
+ # Install Nvidia Modeset module:
+ #
+ # "nvidia-modeset.ko does not provide any new user-visible functionality or interfaces to third party applications.
+ # However, in a later release, nvidia-modeset.ko will be used as a basis for the modesetting interface provided by
+ # the kernel's direct rendering manager (DRM)."
+ install -Dm644 $_pkg/kernel-$_extramodules/nvidia-modeset.ko \
+ "$pkgdir"/$_path/nvidia-modeset.ko
+
# Compress
gzip "$pkgdir"/$_path/nvidia*.ko
done