summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2024-02-02 17:29:59 -0300
committerDaniel Bermond2024-02-02 17:29:59 -0300
commit4aa19ade390161712389e643950d7f3443b4ba31 (patch)
tree77380db7052b1028efba275b06b81472b3cbb5a5 /PKGBUILD
parent6ec726a001c61d2b9e4d3669af66c151e411e36c (diff)
downloadaur-4aa19ade390161712389e643950d7f3443b4ba31.tar.gz
Add fix for linux 6.7.3 and 6.6.15
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5adfa6c8d684..bbea4eb70046 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname=nvidia-beta-dkms
pkgver=550.40.07
-pkgrel=1
+pkgrel=2
pkgdesc='NVIDIA driver sources for linux (beta version)'
arch=('x86_64')
url='https://www.nvidia.com/'
@@ -22,10 +22,12 @@ options=('!strip')
_pkg="NVIDIA-Linux-${CARCH}-${pkgver}-no-compat32"
source=("https://us.download.nvidia.com/XFree86/Linux-${CARCH}/${pkgver}/${_pkg}.run"
'110-nvidia-change-dkms-conf.patch'
- '120-nvidia-linux-rt-gift.patch')
+ '120-nvidia-linux-rt-gift.patch'
+ '130-nvidia-linux-fix.patch')
sha256sums=('6d32940a6f4b92f534b42d68aa0974a7fcd6b5c0abb4d900b43c07f2326da85a'
'4d18fbf00ffde21d22fee704c94c041e27aab2074a95dfff25d4666a6fcba9dd'
- '291bc6568e18496a4c2e732fd8616f6d536d8e9f3ab51f1959e3fc08f0de126b')
+ '291bc6568e18496a4c2e732fd8616f6d536d8e9f3ab51f1959e3fc08f0de126b'
+ '59958c134261a53edb641ba3c96b13e397d1903ec3637c8be8d61141356292de')
prepare() {
# extract the source file
@@ -35,6 +37,10 @@ prepare() {
patch -d "$_pkg" -Np1 -i "${srcdir}/110-nvidia-change-dkms-conf.patch"
patch -d "$_pkg" -Np1 -i "${srcdir}/120-nvidia-linux-rt-gift.patch"
+
+ # fix incompat with Linux 6.6.15 and 6.7.3
+ # from Gentoo at https://github.com/gentoo/gentoo/commit/c64caf5352e8b82edbaa2204aaf055cbcabfc8d1
+ patch -d "$_pkg" -Np1 -i "${srcdir}/130-nvidia-linux-fix.patch"
}
package() {