summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2018-05-01 15:38:01 -0400
committergraysky2018-05-01 15:38:01 -0400
commitf118d2c7853fd481a25de5dc845bc6757a8f1cea (patch)
tree33393d26f4fa00145b6e17e437b376cdbd69e7e6 /PKGBUILD
parent446c855ed88a83d88efcf3dd36cbb1cb720e5184 (diff)
downloadaur-f118d2c7853fd481a25de5dc845bc6757a8f1cea.tar.gz
Update to 390.48-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 471475eb89af..e4a98a375399 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,34 @@
pkgname=nvidia-ck
pkgver=390.48
-pkgrel=1
+pkgrel=2
epoch=1
-_extramodules=extramodules-4.15-ck
+_extramodules=extramodules-4.16-ck
_pkgdesc="NVIDIA drivers for linux-ck."
pkgdesc="$_pkgdesc"
arch=('x86_64')
url="http://www.nvidia.com/"
-depends=('linux-ck>=4.15' 'linux-ck<4.16' 'libgl' "nvidia-utils=${pkgver}")
-makedepends=('linux-ck-headers>=4.15' 'linux-ck-headers<4.16' 'nvidia-libgl')
+depends=('linux-ck>=4.16' 'linux-ck<4.17' 'libgl' "nvidia-utils=${pkgver}")
+makedepends=('linux-ck-headers>=4.16' 'linux-ck-headers<4.17' 'nvidia-libgl')
conflicts=('nvidia-340xx-ck')
#groups=('ck-generic')
#replaces=()
license=('custom')
options=('!strip')
-source=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-sha256sums=('2d4bf72801f101a85df6fd1464021380ad51f5a30df05dadaf1fb546a175a441')
+source=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run"
+kernel-4.16.patch)
+sha256sums=('2d4bf72801f101a85df6fd1464021380ad51f5a30df05dadaf1fb546a175a441'
+ '622ac792ec200b2239cb663c0010392118b78c9904973d82cd261165c16d6385')
_pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
+
+ # Restore phys_to_dma support (still needed for 396.18)
+ # https://bugs.archlinux.org/task/58074
+ patch -Np1 -i ../kernel-4.16.patch
}
build() {