summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulie Shapiro2022-07-26 13:14:10 -0500
committerJulie Shapiro2022-07-26 13:14:10 -0500
commit7dc1bfba3364b375f2c6faa847c2b2f5c53cb236 (patch)
treeac8cff311b467f4a5b52411ba3885d60b52f2974 /PKGBUILD
parent0c7a8ea4b2a2615ec99fa8ebf62c77b4e19f817c (diff)
downloadaur-7dc1bfba3364b375f2c6faa847c2b2f5c53cb236.tar.gz
fix linking issue from LDFLAGS
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 95af9d70b687..c5393267050f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname=nvidia-container-runtime
# identical to nvidia-container-toolkit's PKGBUILD.
pkgver=3.10.0
-pkgrel=1
+pkgrel=2
toolkit_ver=1.10.0
@@ -36,15 +36,18 @@ build() {
GO111MODULE=auto \
GOPATH="${srcdir}/gopath" \
+ GOOS=linux \
go build -v \
-modcacherw \
-buildmode=pie \
-gcflags "all=-trimpath=${PWD}" \
-asmflags "all=-trimpath=${PWD}" \
- -ldflags "-s -w -extldflags ${LDFLAGS}" \
-o bin \
"./..."
- # -trimpath \ # only go > 1.13
+ # using LDFLAGS is busted because -Wl breaks linking to cuDriver* for some reason :(
+ #-ldflags "-s -w -extldflags \"${LDFLAGS}\"" \
+ # only go > 1.13
+ # -trimpath \
# go leaves a bunch of local stuff with 0400, making it break future `makepkg -C` _grumble grumble_
GO111MODULE=auto \