summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDet2016-08-26 20:21:09 +0300
committerDet2016-08-26 20:21:09 +0300
commit8d1c2f73eb5fefac56a461a4032f01b2d7adedbb (patch)
treeee45a8b5c41c51819deb8814b2395cb57f0bacff /PKGBUILD
parent36045de20385e23420fc55bb30572f7a80683c42 (diff)
downloadaur-8d1c2f73eb5fefac56a461a4032f01b2d7adedbb.tar.gz
Fix 4.8 patch & i686 build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b7294c940d01..87bb10c2481f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,11 +27,13 @@ fi
# Source
source=('20-nvidia.conf'
+ 'linux-4.7.patch'
'linux-4.8.patch')
source_i686=("http://us.download.nvidia.com/XFree86/Linux-x86/$pkgver/NVIDIA-Linux-x86-$pkgver.run")
source_x86_64=("http://us.download.nvidia.com/XFree86/Linux-x86_64/$pkgver/$_pkg.run")
md5sums=('2640eac092c220073f0668a7aaff61f7'
- '575708b8db401ff82ee4a26e491cc0da')
+ '4ce4db437695790a73f132651a601889'
+ '5a08e2109ebe7e597348796743337c01')
md5sums_i686=('7b7466e23ae6ffa97106c9749aee2628')
md5sums_x86_64=('cbe2cee787e07f8775a3fd994c9263a9')
[[ $_pkg = NVIDIA-Linux-x86_64-$pkgver ]] && md5sums_x86_64=('65b99201ca894ea9a878593fbb19f0a3')
@@ -79,7 +81,7 @@ prepare() {
# Check version
if (( $(vercmp $_kernel $_major_patch) >= 0 )); then
msg2 "Applying $_patch..."
- patch -p1 -i "$_patch"
+ patch -p0 -i "$_patch"
fi
done
}