summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDet2016-08-26 20:21:13 +0300
committerDet2016-08-26 20:21:13 +0300
commitdc719819986853b93dbbac0ec8f83bf6257d6dad (patch)
tree23a19abc952b6fe06f7ec13b6c843d828242ff75 /PKGBUILD
parent6366d3b40e8ee1ec99715bffae4f585230796074 (diff)
downloadaur-dc719819986853b93dbbac0ec8f83bf6257d6dad.tar.gz
Fix 4.8 patch & i686 build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e848c3dd85d8..05d2aee35e7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,11 +27,13 @@ fi
# Source
source=('20-nvidia.conf'
+ 'linux-4.7.patch'
'linux-4.8.patch')
source_i686=("http://us.download.nvidia.com/XFree86/Linux-x86/$pkgver/NVIDIA-Linux-x86-$pkgver.run")
source_x86_64=("http://us.download.nvidia.com/XFree86/Linux-x86_64/$pkgver/$_pkg.run")
md5sums=('2640eac092c220073f0668a7aaff61f7'
- '575708b8db401ff82ee4a26e491cc0da')
+ '4ce4db437695790a73f132651a601889'
+ '5a08e2109ebe7e597348796743337c01')
md5sums_i686=('7b7466e23ae6ffa97106c9749aee2628')
md5sums_x86_64=('cbe2cee787e07f8775a3fd994c9263a9')
[[ $_pkg = NVIDIA-Linux-x86_64-$pkgver ]] && md5sums_x86_64=('65b99201ca894ea9a878593fbb19f0a3')
@@ -86,7 +88,7 @@ prepare() {
# Check version
if (( $(vercmp $_kernel $_major_patch) >= 0 )); then
msg2 "Applying $_patch for $_kernel..."
- patch -p2 -i "$_patch"
+ patch -p1 -i "$_patch"
fi
# Return