summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgreenbagels2016-06-14 01:44:03 -0400
committergreenbagels2016-06-14 01:44:03 -0400
commit1c217d37957743524c3f2b573ae8f76b4d1def6f (patch)
treeb835e5b6e8655086a810e8d151bcb737868e6b88 /PKGBUILD
parent8dc894f642835e6bc473d8a1c7770351790d32a1 (diff)
downloadaur-1c217d37957743524c3f2b573ae8f76b4d1def6f.tar.gz
Update for driver version 367.27
The patch has been changed to a custom uploaded patch that slightly alters the previous 364.12 patch as the driver source has slightly changed. Once the grsecurity team feels the need to update the upstream patch that has been so graciously provided before, this package will be changed back accordingly.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 515b7866bc62..366e148288ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,23 +6,24 @@
pkgbase=nvidia-grsec
pkgname=(nvidia-grsec nvidia-grsec-dkms)
-pkgver=364.19
+pkgver=367.27
_extramodules=extramodules-4.5.7-grsec
-pkgrel=7
+pkgrel=1
pkgdesc="NVIDIA drivers for linux-grsec kernel"
arch=('i686' 'x86_64')
url="http://www.nvidia.com/"
makedepends=('nvidia-libgl' "nvidia-utils=${pkgver}" 'linux-grsec' 'linux-grsec-headers>=4.5' 'linux-grsec-headers<4.6')
license=('custom')
options=(!strip)
-#source=("https://www.grsecurity.net/~paxguy1/nvidia-drivers-${pkgver}-pax.patch")
-#Latest patch not on the website, and no errors reported (as of this change) with this patch
-source=("https://www.grsecurity.net/~paxguy1/nvidia-drivers-364.12-pax.patch")
+#source=("https://www.grsecurity.net/~paxguy1/nvidia-drivers-364.12-pax.patch")
+#Current patch is ever-so-slightly off, and rather than requiring patchutils, here's an edited one
+#Credits to pipacs on OFTC for helping with the patch!
+source=("https://u.teknik.io/3xgS9.patch")
source_i686=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-sha512sums=('a83c264564850d5e31d5673ec332f5a55f95ebdd07415a72bd702e635bca1d4b5a5d30531be89376e2846fee46e273620e0001dd4381cc3b41127e4764901f27')
-sha512sums_i686=('2b1cb0769d8c4d817588ab1071dbdbeda54291274392fd74009fc666bf198e6fcba1fe15db9d925a56ef98b147b48e58042a079b4f5773e95efe85531e25b01a')
-sha512sums_x86_64=('3a383ad10f9f01e2bc9ff1f62dcaad205f4586cb0e72568a24ac504f991af5961e5730262608596435b549c0d05110e2b3a51b424f383b5ad5b0de147c2fd1c8')
+sha512sums=('a5f825b672f14197a73fd2535086f91f5355de1b98497b0a74333d096c79c8b0a23f854b40575247f96e5adb38ccc09fefebf8e0313ca195be9194c27f894f7a')
+sha512sums_i686=('54302f0de936a859561b756989ff84f73afe41dfb89ed680ee3df3c46b0de9d57eaf2d07876dea0eb1154fbc1a716d4d3e693cb7eaa7ab325b4bbee569ddb709')
+sha512sums_x86_64=('bb1cdfb28cf2c2216b39380994aedd4c5568d83e759aeb588be0f4784475a34c23410c2d6076b05a8163cc6cd1428c6a79e172bb3327e0160c4adf34454d3968')
[[ "$CARCH" = "i686" ]] && _pkg="NVIDIA-Linux-x86-${pkgver}"
[[ "$CARCH" = "x86_64" ]] && _pkg="NVIDIA-Linux-x86_64-${pkgver}-no-compat32"
@@ -31,9 +32,8 @@ prepare() {
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
# patches here
- # change this when the patch comes back to the same version as the driver
- # patch -Np1 -i "../nvidia-drivers-${pkgver}-pax.patch"
- patch -Np1 -i "../nvidia-drivers-364.12-pax.patch"
+ # Using the updated grsecurity-provided patch
+ patch -Np1 -i "../3xgS9.patch"
cp -a kernel kernel-dkms
cd kernel-dkms